Ask Your Question
0

robot_localization: imu0 type error

asked 2020-01-29 18:30:33 -0500

rhodal gravatar image

updated 2020-01-30 05:57:18 -0500

gvdhoorn gravatar image

I am using Ubuntu 14.04 with ROS indigo.

I have the following launch file:

<launch>
<node pkg="robot_localization" type="ekf_localization_node" name="robot_localization_ekf_node_odom" clear_params="true">

    <param name="frequency" value="30." />
    <param name="sensor_timeout" value="0.2" />
    <param name="two_d_mode" value="true" />
    <param name="publish_tf" value="true" />
    <param name="map_frame" value="map" />
    <param name="odom_frame" value="odom" />
    <param name="base_link_frame" value="base_link" />
    <param name="world_frame" value="odom" />
    <param name="print_diagnostics" value="true" />
    <remap from="odometry/filtered" to="odometry/filtered_odom" />
    <param name="imu0" value="/imu" />
    <rosparam param="imu0_config">[false, false, false,
                                   false, false, false,
                                   flase, false, false,
                                   false, false, true,
                                   true,  true,  false]</rosparam>
  </node>
</launch>

When I run this file it shows the following error:

core service [/rosout] found 
process[robot_localization_ekf_node_odom-1]: started with pid [24615]
process[robot_localization_ekf_node_map-2]: started with pid [24616] 
[FATAL] [1580342908.864074517]: Could not read sensor update configuration for topic imu0 (type: 7, expected: 7). Error was type error
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-01-30 07:30:48 -0500

Phgo gravatar image

updated 2020-01-30 07:33:15 -0500

You apparently have a typo in the 7th element in the configuration matrix.

<rosparam param="imu0_config">[false, false, false,
                               false, false, false,
                               **flase**, false, false,
                               false, false, true,
                               true,  true,  false]</rosparam>
edit flag offensive delete link more

Comments

Thank you so much!!! Just fixed it, the error is gone.

rhodal gravatar image rhodal  ( 2020-01-30 11:00:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-01-29 18:30:33 -0500

Seen: 111 times

Last updated: Jan 30 '20