Ask Your Question
0

unable to contact ROS master at

asked 2020-01-28 09:58:07 -0600

xinxinxin gravatar image

updated 2020-01-28 11:37:43 -0600

gvdhoorn gravatar image

Hi, This is a simple question but troubled me hours.

I am following the turtlebot3 tutorial. Setting up the bashrc of host-pc with PC IP address 192.168.48.132 :

export ROS_MASTER_URI=http://**192.168.48.132**:11311
export ROS_HOSTNAME=**192.168.48.132**

Setting up the bashrc of turtlebot3 with its own IP 192.168.137.192 :

export ROS_MASTER_URI=http://**192.168.48.132**:11311
export ROS_HOSTNAME=**192.168.137.192**

Then, run the roscore on remote PC with the printout like this:

Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://192.168.48.132:38089/
ros_comm version 1.12.14

SUMMARY

PARAMETERS
 * /rosdistro: kinetic
 * /rosversion: 1.12.14

NODES

auto-starting new master
process[master]: started with pid [2167]
ROS_MASTER_URI=http://192.168.48.132:11311/

setting /run_id to ee0e1f5e-41df-11ea-8d67-000c29f89067
process[rosout-1]: started with pid [2180]
started core service [/rosout]

then run

roslaunch turtlebot3_bringup turtlebot3_robot.launch on turtlebot3

get 'unable to contact ROS master at [http://192.168.48.132:11311/]'

the bashrc setting ip is the same but why the turtlebot cannot find the ros master?

Thank you

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-01-28 10:27:41 -0600

xinxinxin gravatar image

solved. It is because I am using Virtual Machine. The virtual ubuntu's ip address is 192.168.48.132 which is not the real wireless router address which starts with 192.168.137.xx

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-01-28 09:58:07 -0600

Seen: 20 times

Last updated: Jan 28