How to prevent turtlebot3_core node from publishing tf?

asked 2020-01-27 07:32:35 -0600

valerylo gravatar image

I have a turtlebot3 burger, with ROS melodic, ubuntu 18.04.

When I run turtlebot3_core node, it publishes a tf between odom and base_footprint, based on its imu and the wheels' encoders. I would like to stop publishing this tf because I wants to use visual odometry insteed. However this node seems to come from the opencr card, so I do not have any control on the published topics.

Is there any way to force this node not publishing anymore on this topic?

edit retag flag offensive close merge delete

Comments

1

The obviously one is to change the code of the opencr firmware, it is open source, related question: 334874

A "dirty" way could be to remap the tf topic to somewhere where it is never read, e.g. <remap from="tf" to="tfdisabled"/>

Humpelstilzchen gravatar imageHumpelstilzchen ( 2020-01-28 02:33:57 -0600 )edit

thanks. The dirty way works well :)

valerylo gravatar imagevalerylo ( 2020-01-29 10:13:22 -0600 )edit