Ask Your Question
0

How to disable Multicast in cyclone DDS?

asked 2020-01-21 08:13:21 -0600

charvi gravatar image

updated 2020-01-21 08:20:05 -0600

Hello everyone ! I have ROS 2 setup with cyclone dds as ros middleware implementation on both, my laptop and Jetson Nano. I am following the following link for the QOS setting : https://github.com/eclipse-cyclonedds...

Also my config.xml file is as below :

 <?xml version="1.0" encoding="UTF-8" ?>
 <?xml-model href="https://raw.githubusercontent.com/eclipse-cyclonedds/cyclonedds/master/etc/cyclonedds.xsd" schematypens="http://www.w3.org/2001/XMLSchema" ?><CycloneDDS xmlns="https://cdds.io/config">
<Domain Id= "any">
<General>
    <NetworkInterfaceAddress>auto</NetworkInterfaceAddress>
    <AllowMulticast>false</AllowMulticast>
    <EnableMulticastLoopback>true</EnableMulticastLoopback> 
</General>      
<Compatibility>
      <StandardsConformance>lax</StandardsConformance> </Compatibility>    
</Domain> 
</CycloneDDS>

But if I set false the Allow Multicast tag then I am unable to subscribe(from laptop) the topic published on my own laptop. I have been trying to solve it out by setting other tags but everytime it fails . I am using publisher and subscriber code from the demo_nodes_py package of the ros2.

Ubuntu : 18.04 ROS2 Distro : Dashing

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-01-26 02:22:23 -0600

Ting.Chang gravatar image

Maybe you should set Peer Address when multicast is disabled.

Otherwise, you can set spdp instead of false.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2020-01-21 08:13:21 -0600

Seen: 26 times

Last updated: Jan 21