ImportError undefined symbol moveit_commander

asked 2020-01-15 06:45:31 -0600

lucarinelli gravatar image

updated 2020-01-16 03:47:10 -0600

Hi all, I have a simple python script inspired by the moveit tutorials using moveit_commander.

It has always worked with no problems until a few days ago when it started doing this:

lrinelli@laptop:~$ rosrun test_pkg test_print_state.py __ns:=edo
Traceback (most recent call last):
  File "/home/lrinelli/ws_moveit/src/test_pkg/src/test_print_state.py", line 6, in <module>
    import moveit_commander
  File "/home/lrinelli/ws_moveit/devel/lib/python2.7/dist-packages/moveit_commander/__init__.py", line 35, in <module>
    exec(__fh.read())
  File "<string>", line 2, in <module>
  File "/home/lrinelli/ws_moveit/src/moveit/moveit_commander/src/moveit_commander/roscpp_initializer.py", line 35, in <module>
    from moveit_ros_planning_interface import _moveit_roscpp_initializer
ImportError: /home/lrinelli/ws_moveit/devel/lib/libmoveit_py_bindings_tools.so.1.0.1: undefined symbol: _ZN5boost6python23throw_error_already_setEv

I'm using:

  • ROS Melodic on Ubuntu 19.10 compiled from source
  • MoveIt compiled from source, branch master
  • Python 2.7

I was thinking that this could be related to boost and that a system update may have created some issue with dependencies but I've checked and no update related to boost. There have been some updates related to python3 but they should not be related(?).

I have already tried rebuilding from scratch ROS, MoveIt and all my packages with no result.

Any idea?

Thanks in advance

edit retag flag offensive close merge delete