Ask Your Question
0

Problem with index file installing kinetics on ubuntu 16.04

asked 2020-01-05 05:55:35 -0500

FranJRO gravatar image

updated 2020-01-05 06:03:54 -0500

gvdhoorn gravatar image

I'm trying to install kinetics ros on ubuntu 16.04, followig the guide http://wiki.ros.org/kinetic/Installat...

The problem starts when I code this in terminal:

sudo apt-get update

The resume of the result is this:

W: The repository «http://packages.ros.org/ros/ubuntu $ (lsb_release Release» does not have a Publication file.
N: Data from a repository like this cannot be authenticated and therefore its use is potentially dangerous.
N: See the apt-secure (8) manual page for details on creating repositories and configuring users.
E: Failed to get http://packages.ros.org/ros/ubuntu/dists/$(lsb_release/-sc)/binary-amd64/Packages 404 Not Found [IP: 140.211.166.134 80]
E: Some index files could not be downloaded, omitted, or old ones used instead.

I'm new in this, so I suposed that the problem was kind of resolved using the 'old ones instead'. So I've continued with the guide and I code this in terminal:

sudo apt-get install ros-kinetic-desktop-full

And the resume of the result is the following:

Errors were encountered while processing:
 ros-kinetic-eigen-stl-containers
  ros-kinetic-geometric-shapes
  ros-kinetic-collada-urdf
  ros-kinetic-robot-model
  ros-kinetic-robot
  ros-kinetic-desktop
  ros-kinetic-simulators
 ros-kinetic-desktop-full
E: Sub-process / usr / bin / dpkg returned an error code (1)

I dont know if this two problem are related, but I dont know how to start to fix its. I apreciate your help. Thanks for your time.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2020-01-05 06:08:34 -0500

gvdhoorn gravatar image

The cause is shown in the error message:

W: The repository «http://packages.ros.org/ros/ubuntu $ (lsb_release Release» does not have a Publication file.

and:

E: Failed to get http://packages.ros.org/ros/ubuntu/dists/$(lsb_release/-sc)/binary-amd64/Packages 404 Not Found [IP: 140.211.166.134 80]

Notice how the URL is shown as:

http://packages.ros.org/ros/ubuntu/dists/$(lsb_release/-sc)/binary-amd64/Packages

That is not the correct URL, and it looks like something went wrong during the previous steps where you add the repository information (ie: "Setup your sources.list"). The $(lsb_release/-sc) part is obviously incorrect.

Simplest way to fix this is to re-run the command to add the repository, but this time, make sure it is completely correct:

sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu $(lsb_release -sc) main" > /etc/apt/sources.list.d/ros-latest.list'

Make sure you execute this as a single command (ie: no line-breaks). And make sure there are no additional slashes added anywhere.

Finally, just to avoid having to diagnose this later, make sure lsb_release -c actually returns something (and does not error out).

edit flag offensive delete link more

Comments

Hi, thanks for your answer. I tried what you told me and the result is the same. I checked the command and I don't see any error. Any other idea?

Thanks anyway.

FranJRO gravatar image FranJRO  ( 2020-01-07 14:29:15 -0500 )edit

Please show the exact command line you executed.

Don't copy it from my answer. Copy it from your terminal. If you've already closed the terminal, use "arrow up" to go back in your history.

Also show us the output of:

cat /etc/apt/sources.list.d/ros-latest.list
gvdhoorn gravatar image gvdhoorn  ( 2020-01-07 14:30:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-01-05 05:55:35 -0500

Seen: 30 times

Last updated: Jan 05