Dual arm robot with aubo_i5

asked 2020-01-03 05:19:38 -0600

Abhishekpg gravatar image

updated 2020-01-05 23:51:45 -0600

Hi ,

im trying to control two aubo_i5 robot arms simultaneously. But my both arms have different ip address. So i dont know how to control the arms. I tried launching two instances of moveit with different namespaces. But im getting the error. Even when im using single robot,but giving the namespace im getting the same error. I have seen multi robot system of motoman. But they have said they are using single controller with single ip. But im not familiar with how the controllers work as im new to this area. My move it launch file and the error is as shown below. Any help is much appreciated.

    <?xml version="1.0"?>
<launch>

<group ns="left">

 <!-- load the robot_description parameter before launching ROS-I nodes -->

  <rosparam command="load" file="$(find aubo_i5_moveit_config)/config/joint_names.yaml"/>

  <include file="$(find aubo_i5_moveit_config)/launch/planning_context.launch" >
    <arg name="load_robot_description" value="true" />
  </include>
  <!-- The planning and execution components of MoveIt! configured to run -->
  <!-- using the ROS-Industrial interface. -->

  <!-- the "sim" argument controls whether we connect to a Simulated or Real robot -->
  <!--  - if sim=false, a robot_ip argument is required -->
  <arg name="sim" default="false" />
  <arg name="robot_ip" value="192.168.1.103" />

  <!-- joint_trajectory_action: provides actionlib interface for high-level robot control -->
  <node pkg="aubo_controller" type="aubo_joint_trajectory_action" name="aubo_joint_trajectory_action"/>


 <!-- industrial_robot_simulator: accepts robot commands and reports status -->
  <node pkg="aubo_controller" type="aubo_robot_simulator" name="aubo_robot_simulator"/>
  <param name="/aubo_controller/velocity_scale_factor" value= "1.0"/>

  <!-- run the "real robot" interface nodes -->
  <!--   - this typically includes: robot_state, motion_interface, and joint_trajectory_action nodes -->
  <!--   - replace these calls with appropriate robot-specific calls or launch files -->
  <!--<group unless="$(arg sim)">
    <include file="$(find aubo_i5_moveit_config)/launch/robot_interface.launch" >
      <arg name="robot_ip" value="$(arg robot_ip)"/>
    </include>
  </group> -->

 <!-- publish the robot state (tf transforms) -->
  <node name="aubo_driver" pkg="aubo_driver" type="aubo_driver" >
  <param name="/server_host" type="str" value="$(arg robot_ip)"/>
  <!--<param name="/server_host" value="127.0.0.1"/> -->
  </node>

  <!-- publish the robot state (tf transforms) -->
  <node name="robot_state_publisher" pkg="robot_state_publisher" type="robot_state_publisher" />

  <include file="$(find aubo_i5_moveit_config)/launch/move_group.launch">
    <arg name="publish_monitored_planning_scene" value="true" />
  </include>

  <include file="$(find aubo_i5_moveit_config)/launch/moveit_rviz.launch">
    <arg name="config" value="true"/>
  </include> 
  <!--<include file="$(find aubo_i5_moveit_config)/launch/default_warehouse_db.launch" />-->
</group>



</launch>

Error

:

[ WARN] [1578050151.250107995]: Waiting for aubo_i5_controller/follow_joint_trajectory to come up
[ INFO] [1578050151.428664640]: Starting scene monitor
[ INFO] [1578050151.439528930]: Listening to '/left/move_group/monitored_planning_scene'
[ INFO] [1578050151.451725448]: waitForService: Service [/left/get_planning_scene] has not been advertised, waiting...
[ INFO] [1578050156.458903368]: Failed to call service get_planning_scene, have you launched move_group? at /tmp/binarydeb/ros-kinetic-moveit-ros-planning-0.9.17/planning_scene_monitor/src/planning_scene_monitor.cpp:491
[ INFO] [1578050156.882281566]: Constructing new MoveGroup connection for group 'manipulator_i5' in namespace ''
[ INFO] [1578050156.883086371]: Starting scene monitor
[ INFO] [1578050156.897316732]: Listening to '/move_group/monitored_planning_scene'
[ INFO] [1578050156 ...
(more)
edit retag flag offensive close merge delete

Comments

This may not be what you came here to hear, but have you asked Aubo about this? It's their product, and they appear to have ROS support, so you may want to ask their support.

gvdhoorn gravatar imagegvdhoorn ( 2020-01-06 02:10:54 -0600 )edit