Ask Your Question
1

Failed to find rosdep ...

asked 2012-05-14 21:06:50 -0500

liborw gravatar image

updated 2012-05-14 21:07:45 -0500

Hi,

I have copied the gsl package into my ros workspace, it appears in rospack list, but I'm getting this warnings:

Failed to find rosdep gsl for package my_package on OS:ubuntu version:lucid
WARNING: Rosdeps [u'gsl'] could not be resolved

[ rosmake ] WARNING: Rosdep did not detect the following system dependencies as installed: gsl Consider using --rosdep-install option or `rosdep install my_package`

However it compiles and works ok, but there is probably something wrong? Can you halp to get rid of this warnings?

Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-05-14 21:10:40 -0500

Cody gravatar image

In my_package's manifest.xml change

<rosdep name="gsl" />

to

<depend package="gsl" />
edit flag offensive delete link more

Comments

1

Thanks, but actually in my_package the depend was correct but in the gsl package there was <rosdep name="gsl" /> so I have change it to <rosdep package="gsl" /> and it works.

liborw gravatar image liborw  ( 2012-05-14 21:19:25 -0500 )edit

Ah. Glad to hear it wasn't too tricky. There seem to be some strange issues with rosdep these days.

Cody gravatar image Cody  ( 2012-05-15 07:39:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-14 21:06:50 -0500

Seen: 550 times

Last updated: May 14 '12