Ask Your Question
1

ERROR: Ambiguous workspace

asked 2012-05-14 19:45:28 -0500

Sam_h gravatar image

Hello everyone,

On the process of installing rosjava_core, on the line "rosws merge /opt/ros/fuerte/.rosinstall" I get the following error:

"ERROR: Ambiguous workspace: ROS_WORKSPACE=/home/sam/my_workspace, /home/sam/my_workspace/android_core/.rosinstall"

As you probably have noticed, I changed the "electric" to "fuerte" in the command. Please correct me on that if I'm wrong.

If not, does anyone have any idea why I get this ambiguity problem?

Thanks so much.

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
1

answered 2012-05-15 23:10:20 -0500

KruseT gravatar image

You would have to disambiguate every time you are in an ambiguous situation. What causes ambiguity is having multiple '.rosinstall' files lying around.

You could rename or delete the one in /home/sam/my_workspace/android_core.

Is there a particular reason you want a .rosinstall there as well, as opposed to having the file named e.g. android_core.rosinstall?

rosws could have a switch that says it should use ROS_WORKSPACE in case of ambiguity, like --env or so. But for now I believe it is better to warn people that they have multiple .rosinstall files lying around.

edit flag offensive delete link more
2

answered 2012-05-15 03:57:07 -0500

KruseT gravatar image

rosws tries to infer which workspace you want to work with. It looks at your current path and above, and also at the $ROS_WORKSPACE environment variable.

In this case it could not decide which .rosinstall you wanted to modify, since there was one at both: /home/sam/my_workspace /home/sam/my_workspace/android_core

You can disambiguate using e.g. -t /home/sam/my_workspace

edit flag offensive delete link more
0

answered 2012-05-15 04:31:39 -0500

Sam_h gravatar image

Thank you so much.

It solved the problem but it seems like that each time I need to add -t /home/sam/my_workspace to the end of rosws. My work space is actually "/home/sam/my_workspace".

Is there anyway that I could permanently fix this?

Thanks.

edit flag offensive delete link more

Comments

1

@Sam_h please accept @KruseT's answer using the checkbox next to his answer. It gives him karma and lets others know your problem is solved.

tfoote gravatar imagetfoote ( 2012-05-17 07:42:29 -0500 )edit
0

answered 2012-05-20 07:43:43 -0500

Sam_h gravatar image

@KurseT Thanks, yeah I figured I had to remove that .rosinstall file and it worked.

Thank you for your responses.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2012-05-14 19:45:28 -0500

Seen: 1,758 times

Last updated: May 20 '12