ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

ROS2 Eloquent Turtlesim Missing Qt platform plugin

asked 2019-12-05 08:54:02 -0500

Arcbound gravatar image

So I recently installed ROS2 Eloquent Elusor on Windows 10 v1909.

When I try to run the turtlesim(v1.1.0) tutorial, while calling "ros2 run turtlesim turtlesim_node" I get the following error: "This application failed to start because it could not find or load the Qt platform plugin "windows" in ""."

I already checked my PATH variable and even added the path to "Python37\Lib\site-packages\PyQt5\Qt\plugins\platforms", but nothing changed. I even reinstalled PyQt5, but this didn't help either.

Any ideas how to solve this?

edit retag flag offensive close merge delete


Having same issue - were you able to solve?

billy gravatar image billy  ( 2019-12-14 01:35:52 -0500 )edit

Same here. Did you solve it?

FjMalFer gravatar image FjMalFer  ( 2019-12-28 03:05:41 -0500 )edit

Same here. I found this post to be helpful:

I ran C:\Qt\5.12.6\msvc2017_64\windeployqt c:\dev\eloquent\turtlesim\turtlesim_node.exe and it fixed the issue by creating the dependencies in the Lib\turtlesim folder.

GregCannon63 gravatar image GregCannon63  ( 2020-01-01 19:42:13 -0500 )edit

works! Thank you!!

FjMalFer gravatar image FjMalFer  ( 2020-01-02 12:31:58 -0500 )edit

Worked for me as well. Thank you. I had seen the other post but didn't have a good idea what to do with it.

billy gravatar image billy  ( 2020-01-04 13:10:39 -0500 )edit

Does this require anything else to be installed besides the python PyQt5 package? I couldn't find windeployqt in PyQt5 files.

Edit: I guess the answer is obvious that GregCannon63 installed Qt 5.12.6, but I guess I'm also trying to understand why this installation was necessary. I followed the instructions for Windows 10 and it still requires this fix.

anonymous userAnonymous ( 2020-04-10 20:46:23 -0500 )edit

Sorry but I can't really understand what GregCannon63 was doing. Can anyone explain exactly what command to type into cmd? I'm very new even to cmd so i'm a bit lost at the moment.

BennyBot gravatar image BennyBot  ( 2020-07-22 09:58:21 -0500 )edit

I too have this problem. I followed the instructions for Windows 10 install. Installed ROS2 Foxy

ninjaCoda20 gravatar image ninjaCoda20  ( 2021-05-20 05:13:50 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2022-06-01 11:13:36 -0500

domage gravatar image


It seems like something over-rights the default location of the QL platform dll.

In my case, the following helped: Create an environment variable:

  • Value: C:\dev\ros2_foxy\bin\platforms\

Unfortunately, I am not sure how it would fit your specific configuration

edit flag offensive delete link more

Question Tools



Asked: 2019-12-05 08:51:55 -0500

Seen: 1,366 times

Last updated: Dec 05 '19