Ask Your Question
0

how to fix the conflict about boost 1.67 and boost 1.58 in raspberry pi 4?

asked 2019-11-27 02:04:50 -0600

Googleking gravatar image

In https://wiki.ros.org/ROSberryPi/Insta...

setction 3.3 Building the catkin Workspace "To fix this error try installing boost 1.58 manually"

Could somebody help me how to do when the wiki say :"instead simply pointed to by cmake's BOOST_INCLUDEDIR and BOOST_LIBRARYDIR, boost's build output actually shows you how."?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-11-28 21:30:36 -0600

Googleking gravatar image

When i have compiled the boost library from the 1.58 boost source code, the screen shows:

The Boost C++ Libraries were successfully built!

The following directory should be added to compiler include paths:

/home/pi/Downloads/boost_1_58_0

The following directory should be added to linker library paths:

/home/pi/Downloads/boost_1_58_0/stage/lib

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

So i need to change the CmakeList.txt in the module src document what i need to compile, right? could anyone teach me how to instead the boost 1.58 can avoid the error about rviz segement fault by using 1.67?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-11-27 02:04:50 -0600

Seen: 52 times

Last updated: Nov 28