Testing ROS on two machines

asked 2019-11-22 13:41:28 -0600

John-john gravatar image

updated 2019-11-24 04:38:04 -0600

gvdhoorn gravatar image

I just test ROS on two machines (laptop and raspberry pi3).

My machines exist in the local network (have an connection throw router by WiFi).

I run roscore and listener node on the raspberry, then I export ROS_MASTER_URI of raspberry and run talker node on laptop and get this message:

[ERROR] [1574449179.295281]: Unable to immediately register with master node [http://john-raspberry:11311]: master may not be running yet. Will keep trying.

I tried to export ROS_IP where I pointed raspberry ip.

When i call roswtf, it gives me:

Found 2 warning(s).
Warnings are things that may be just fine, but are sometimes at fault
WARNING Cannot resolve hostname in ROS_MASTER_URI [http://john-raspberry:11311]Unknown host john-raspberry
WARNING ROS_IP may be incorrect: ROS_IP [192.168.0.12] does not appear to be an IP address of a local network interface (one of ['127.0.0.1', '192.168.0.11']).

I have ROS melodic and Ubuntu 18.04

edit retag flag offensive close merge delete

Comments

Follow this line by line: http://wiki.ros.org/ROS/NetworkSetup I suggest using the IP number for master instead of the alias. Go to your router and get the IP addresses of all on the network and makes sure that router is not preventing communication. You should be able to ping between the computers.

billy gravatar imagebilly ( 2019-11-22 19:24:27 -0600 )edit

Oh, thanks. I just forgot to add IPs to my /etc/hosts

John-john gravatar imageJohn-john ( 2019-11-30 15:15:50 -0600 )edit