Ask Your Question
0

rosserial_client not found after installation

asked 2019-11-11 16:12:45 -0600

roDiBgu gravatar image

updated 2019-11-12 03:24:48 -0600

gvdhoorn gravatar image

Hi All,

I am trying to install rosserial library on ros kinetic and ros_lib for Arduino IDE.

I followed link#0 instruction for rosserial manual installation.

All steps finished successfully (rosserial_windows required partial installation of common_msgs library).

After I continued to "2.2 Install ros_lib into the Arduino Environment" link#1, I got ImportError: No module named rosserial_client.

I performed again w/ no success:

catkin_make -DCATKIN_WHITELIST_PACKAGES=rosserial_client
catkin_make install-DCATKIN_WHITELIST_PACKAGES=rosserial_client

Please give me some hint.

Thanks

edit retag flag offensive close merge delete

Comments

There is no need to install rosserial from source (ie: build in your workspace), provided you are running a supported OS on a supported platform. It has been released into Kinetic quite some time ago already for amd64, arm64 and armhf on Debian and Ubuntu. Just run sudo apt install ros-kinetic-rosserial.

See also #q320046 for some info on how to determine whether you can install something using apt.

gvdhoorn gravatar imagegvdhoorn ( 2019-11-12 03:03:20 -0600 )edit

@gvbhoorn, thanks for your reply

I tried using sudo apt-get install-kinetic-rosserial I got: E: Unable to locate package ros-kinetic-rosserial

Also: sudo apt install-kinetic-rosserial I getting: E: Unable to locate package ros-kinetic-rosserial

Have I missed something? Should I run this commands from some specific folder?

roDiBgu gravatar imageroDiBgu ( 2019-11-12 03:35:43 -0600 )edit

According to the status pages (see #q320046 again for an explanation), rosserial has been released for Kinetic on amd64, arm64 and armhf, but perhaps not for your OS.

Are you running something other than Debian or Ubuntu? Or using an unsupported platform? How did you install ROS?

What is the output of lsb_release -a and uname -rvmp?

gvdhoorn gravatar imagegvdhoorn ( 2019-11-12 03:41:41 -0600 )edit

@gvdhoorn

I am using Raspbian Stretch OS, ROS has some compilation issue w/ Buster and I am not skilled enough for t/s

ROS installed according to Link#2

lsb_release -a --> Description: Raspbian GNU/Linux 9.11 (stretch) uname -rvmp --> 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l unknown

roDiBgu gravatar imageroDiBgu ( 2019-11-12 04:01:48 -0600 )edit

I am using Raspbian Stretch OS,

that would indeed be one of the cases where apt wouldn't work, as you've compiled ROS from sources.

So in your case installing rosserial from sources makes sense -- and this is also one of the cases discussed in #q320046).

gvdhoorn gravatar imagegvdhoorn ( 2019-11-12 04:09:39 -0600 )edit

@gvdhoorn Thanks for your support, I will go over #q320046 for better understanding of this issue

roDiBgu gravatar imageroDiBgu ( 2019-11-12 04:14:07 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-11-12 02:41:41 -0600

roDiBgu gravatar image

I assume the issue was solved by

$ source devel/setup.bash (was executed again after rosserial library installation link#0)

After, executed command rosrun rosserial_arduino make_libraries.py <sketchbook/>

ros_lib was successfully created in Arduino sketchbook/libraries/ folder

I think the question can be closed.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-11-11 16:12:45 -0600

Seen: 18 times

Last updated: Nov 12