Ask Your Question
0

Can not run vision_ssd_detect

asked 2019-10-31 07:54:53 -0600

tiensu gravatar image

updated 2019-10-31 08:00:41 -0600

Hi everyone!

I am following this site [https://autoware.readthedocs.io/en/feature-documentation_rtd/DevelopersGuide/PackagesAPI/detection/vision_ssd_detect.html] to install vision_ssd_detect node.

Everything seems to be ok. But when I run the command:

roslaunch vision_ssd_detect vision_ssd_detect

There is an error displayed: RLException: [vision_ssd_detect] is neither a launch file in package [vision_ssd_detect] nor is [vision_ssd_detect] a launch file name

If I run command:

rosrun vision_ssd_detect vision_ssd_detect

There is an error: [rosrun] Couldn't find executable named vision_ssd_detect below /home/sunt/AUTOWARE/SOURCE/autoware.ai/install/vision_ssd_detect/share/vision_ssd_detect

I don't know why?

Can you help suggest me some idea to resolve the problem?

Thank you very much!

My environment:

  • Ubuntu 18.04
  • Autoware 1.12.0 melodic
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-10-31 08:30:14 -0600

Delb gravatar image

Your second error suggest that you do have the package vision_ssd_detect installed but not the executable, did you get any error/warnings when compiling the package ?

For your first error is this a typo when typing the question or have you tried the exact command roslaunch vision_ssd_detect vision_ssd_detect ? Because the last argument should be the full launch file name with the extension :

roslaunch vision_ssd_detect vision_ssd_detect.launch

You should also try the same command as in your tutorial instead.

edit flag offensive delete link more

Comments

Hi Delb! Thank your answer!

I compiling by command: "AUTOWARE_COMPILE_WITH_CUDA=1 colcon build" and there is no error. This is output: Starting >>> vision_ssd_detect Finished <<< vision_ssd_detect [0.46s] Summary: 1 package finished [0.53s]

tiensu gravatar imagetiensu ( 2019-10-31 09:08:21 -0600 )edit

When I run command: roslaunch vision_ssd_detect vision_ssd_detect.launch network_definition_file:=/home/autoware/shared_dir/models/VGGNet/VOC0712/SSD_512x512/deploy.prototxt pretrained_model_file:=/home/autoware/shared_dir/models/VGGNet/VOC0712/SSD_512x512/VGG_VOC0712_SSD_512x512_iter_120000.caffemodel

This is output: ERROR: cannot launch node of type [vision_ssd_detect/vision_ssd_detect]: can't locate node [vision_ssd_detect] in package [vision_ssd_detect] ERROR: cannot launch node of type [detected_objects_visualizer/visualize_rects]: detected_objects_visualizer ROS path [0]=/opt/ros/melodic/share/ros ROS path [1]=/home/sunt/AUTOWARE/SOURCE/autoware.ai/install/gnss/share ROS path [2]=/home/sunt/AUTOWARE/SOURCE/autoware.ai/install/autoware_msgs/share ROS path [3]=/home/sunt/AUTOWARE/SOURCE/autoware.ai/install/autoware_config_msgs/share ROS path [4]=/home/sunt/AUTOWARE/SOURCE/autoware.ai/install/autoware_build_flags/share ROS path [5]=/home/sunt/AUTOWARE/SOURCE/autoware.ai/src/..

tiensu gravatar imagetiensu ( 2019-10-31 09:09:35 -0600 )edit

If you add the params like network_deinition_file then don't type the .launch extension (as in the tutorial)

Delb gravatar imageDelb ( 2019-10-31 09:59:13 -0600 )edit

I did as you said, but it's still error:

RLException: Invalid roslaunch XML syntax: syntax error: line 1, column 0 The traceback for the exception was written to the log file.

tiensu gravatar imagetiensu ( 2019-10-31 11:53:56 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-10-31 07:54:53 -0600

Seen: 32 times

Last updated: Oct 31