Rviz Turtlebot Roomba SLAM error [closed]

asked 2012-05-09 06:40:52 -0600

cg gravatar image

updated 2016-10-24 08:34:01 -0600

ngrennan gravatar image

Dear all,

I am using a roomba 500 series model with kinect (Turtlebot.eu version),in order to perform SLAM with ROS-electric and Linux 11.10 oneiric on both workstation-pc and turtlebot-laptop.

While I follow the tutorial in ROS.org, I get the following error in rviz under laser scanner parameter:

Transform [sender=/openni_manager] For frame [/camera_depth_frame]: Frame [/camera_depth_frame] does not exist.

I tried to change base and fixed frame values to something else, but again no luck.

Can you please let me know if anyone here faced the same error before?



P.S.: My camera node runs with no problem, and Kinect is powered up and normally. I have no problem at all to run the turtlebot follower tutorial, which makes use of Kinect and Roomba rover, runs smoothly.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-03-03 01:39:37.950665


Tell us about the state of your TF tree; rosrun tf view_frames

Mac gravatar image Mac  ( 2012-07-10 10:56:25 -0600 )edit