Ask Your Question
0

Openni_Kinect problem

asked 2012-05-08 13:59:42 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I have ubuntu running ros. I installed Openni_Kinect from the command "sudo apt-get install ros-electric-openni-kinect"

and now I tried this command to test if everything is working, roslaunch openni_camera openni_node.launch

and the error that I get is "[openni_camera] is not a package or launch file name"

any help welcomed

edit retag flag offensive close merge delete

Comments

I followed the steps that you gave me and everything seems to be working. Is there a way to check? and I then went and tried to install openni_kinect again but I get this error

mlandergan gravatar image mlandergan  ( 2012-05-09 02:28:41 -0500 )edit

You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: ros-electric-common : Depends: yaml-cpp0.2.6-dev but it is not going to be installed ros-electric-openni-kinect : Depends: ros-electric-image-common (= 1.6.1-s1328510857~oneiric) but it is

mlandergan gravatar image mlandergan  ( 2012-05-09 02:34:13 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-05-08 23:28:58 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Your environment is not set up correctly. The package openni_camera installs to /opt/ros/electric/stacks/openni_kinect/openni_camera, and that directory is apparently not on your ROS_PACKAGE_PATH environment variable. Follow these steps to fix this.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-08 13:59:42 -0500

Seen: 558 times

Last updated: May 08 '12