Ask Your Question
0

catkin version is not up-to-date?

asked 2019-10-13 04:57:11 -0600

updated 2019-10-13 04:58:35 -0600

gvdhoorn gravatar image

I have Ros in my system and also install ROS2, when I run

~/ros2_ws/install/local_setup.bash

It is say that :

ROS_DISTRO was set to 'kinetic' before. Please make sure that the environment does not mix paths from different distributions.

My ROS env is :

ROS_ROOT=/opt/ros/kinetic/share/ros
ROS_PACKAGE_PATH=/home/golizheh/catkin_ws/src:/opt/ros/kinetic/share
ROS_MASTER_URI=http://localhost:11311
ROS_PYTHON_VERSION=3
ROS_VERSION=2
ROSLISP_PACKAGE_DIRECTORIES=/home/golizheh/catkin_ws/devel/share/common-lisp
ROS_DISTRO=crystal
ROS_ETC_DIR=/opt/ros/kinetic/etc/ros

Coud you pleas help me?

With Best Regards

edit retag flag offensive close merge delete

Comments

catkin version is not up-to-date?

I'm not exactly sure how Catkin is involved here.

Could you explain why you chose this particular title for your question?

gvdhoorn gravatar imagegvdhoorn ( 2019-10-13 05:01:23 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-10-13 05:00:49 -0600

gvdhoorn gravatar image

updated 2019-10-13 05:02:48 -0600

It's likely that you have a line such as:

source /opt/ros/kinetic/setup.bash

in your .bashrc (somewhere near the end probably).

You'll want to remove that, and source manually.

As the warning says: it's not always a good idea to source (ie: activate) both a ROS 1 and a ROS 2 installation at the same time.

(there is a valid reason for doing that though: if you want to use the ROS1<->ROS2 bridge, but seeing as you don't mention it I don't believe you are looking to do that)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-10-13 04:57:11 -0600

Seen: 13 times

Last updated: Oct 13