Ask Your Question
1

Build failed when build the android_core in rosjava [closed]

asked 2012-05-08 00:04:44 -0500

santidoo gravatar image

Hi all, I'm new in this ROS and ROSjava world. I was installing the android_core following the documentation, http://docs.rosjava.googlecode.com/hg/android_core/html/building.html, but when I want to build debug APKs for all android_core packages (./gradlew debug), I'm getting the next error:

  • What went wrong: Execution failed for task ':android_acm_serial:updateProject'. > A problem occurred starting command 'android'.

I'm in the right folder and I have installed the android_core, android SDK and Apache Ant.

Any ideas? Anyone is getting the same error? Thanks in advance

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by damonkohler
close date 2012-05-21 05:51:08

5 Answers

Sort by ยป oldest newest most voted
1

answered 2012-05-14 01:40:54 -0500

santidoo gravatar image

Finally I could solve that problem. The steps that I followed are the next, I hope it help:

  1. Clear the maven cache: $ rm -rf ~/.m2/repository/ros

  2. Delete the rosjava folder (if already installed) and create it again: $ rm -r Workspace $ mkdir -p Workspace

  3. Install rosjava: $ rosinstall ~/Workspace https://kforge.ros.org/appmanandroid/hg/raw-file/tip/appman.rosinstall

  4. Install android_core: $ cd ~/Workspace $ rosws merge http://android.rosjava.googlecode.com/hg/.rosinstall $ rosws update

  5. Build rosjava_core: $ roscd rosjava_core $ ./gradlew install -- optionals $ ./gradlew docs $ ./gradlew test $ ./gradlew eclipse

  6. Install google: $ roscd google $ ./gradlew install

  7. Install android_core: $ roscd android_core $ ./gradlew debug

edit flag offensive delete link more
1

answered 2012-05-13 08:22:13 -0500

dan gravatar image

I have the same issue and do have the path set, so that android launches the SDK managment tool from the directory called out in the error. However, still get this message:

[ERROR] [org.gradle.BuildExceptionReporter] Caused by: java.io.IOException: Cannot run program "android" (in directory "/home/dbarry/rosAndroid/android_core/android_acm_serial"): java.io.IOException: error=2, No such file or directory 14:10:07.223 [ERROR] [org.gradle.BuildExceptionReporter] at org.gradle.process.internal.ExecHandleRunner.run(ExecHandleRunner.java:69) 14:10:07.224 [ERROR] [org.gradle.BuildExceptionReporter] ... 1 more 14:10:07.224 [ERROR] [org.gradle.BuildExceptionReporter] Caused by: java.io.IOException: java.io.IOException: error=2, No such file or directory

In fact, even copying the executable file Android into the directory does not help much-- still get an error at the same spot: * What went wrong: Execution failed for task ':android_acm_serial:updateProject'.

A problem occurred starting command 'android'.

but with a different debug:

[org.gradle.launcher.daemon.server.exec.ExecuteBuild] The daemon has finished executing the build. 14:16:45.529 [DEBUG] [org.gradle.launcher.daemon.server.exec.ReturnResult] Daemon is dispatching the build result: DaemonCommandResult[type=CommandFailure, value=org.gradle.launcher.exec.ReportedException: org.gradle.api.internal.LocationAwareException: Execution failed for task ':android_acm_serial:updateProject'.] 14:16:45.737 [DEBUG] [org.gradle.launcher.daemon.client.DaemonClientInputForwarder] input forwarder stop requested 14:16:45.739 [DEBUG] [org.gradle.launcher.daemon.client.DaemonClientInputForwarder] Dispatching close input message: CloseI

edit flag offensive delete link more
0

answered 2012-05-10 00:38:26 -0500

Hi, I get the same problem, I tried some hints in other posts (http://answers.ros.org/question/32319/installing-rosjava-android_core-is-missing, http://answers.ros.org/question/33104/error-building-android-core2) but the problem wasn't solved. Any solutions? My system: ubuntu 12.04, ros fuerte, android sdk 3.2/3.1, ant1.8.

edit flag offensive delete link more
0

answered 2012-05-10 05:37:46 -0500

damonkohler gravatar image

You should be able to execute "android" in your shell to launch the SDK management tool. If that doesn't work, then you will need to add the SDK to your path.

edit flag offensive delete link more
0

answered 2012-05-21 02:18:34 -0500

Gemini Ma gravatar image

I still have the same problem with Dan after repeating the steps listed by santidoo. Help!

edit flag offensive delete link more

Question Tools

3 followers

Stats

Asked: 2012-05-08 00:04:44 -0500

Seen: 1,888 times

Last updated: May 21 '12