Broken Packages - ROS kinetic

asked 2019-10-07 09:31:01 -0500

marcusvini178 gravatar image

updated 2019-10-07 10:45:32 -0500

gvdhoorn gravatar image

Hello. I trying to install the ROS-Kinteic in Ubuntu 16.04 LTS. But I am having the following trouble:

Packet lists are read... Ready
The dependency tree is created.       
Status information is read in.... Ready
Some packages could not be installed. This may mean that
you have requested an impossible situation or, if you have requested the
Unstable distribution that use some required packages yet
have not been created or have not yet left Incoming.
The following information may help you to resolve the situation:

The following packages have unfulfilled dependencies:
 ros-kinetic-desktop-full : Depends on: ros-kinetic-desktop is not to be installed
                            Depends on: ros-kinetic-perception but should not be installed
                            Depends on: ros-kinetic-simulators but should not be installed
                            Depends on: ros-kinetic-urdf-tutorial but should not be installed
E: Problems cannot be corrected, you have retained broken packages.

I have already tried doing a lot of things, such remove ROS (with purge and autoremove), changing the repositories and adding repositories in the source.list and in the ubuntu system, installing the packages individually, etc. However nothing works. In this ubuntu there also is a drivepx2 installed. Maybe is this the problem? Some conflict?

Thanks in advance.

edit retag flag offensive close merge delete



Hello !

Which tutorial did you follow for installing ROS ? Also, can you edit your question and add the result of the following commands :

1) cat /etc/apt/sources.list.d/ros-latest.list

2) cat /etc/apt/sources.list | grep -v '#'

3) apt list --installed | grep ros

lmathieu gravatar imagelmathieu ( 2019-10-07 10:37:58 -0500 )edit

Hello Imahthies I am trying to install the ROS-kinetic version present in this link The problem is in step 1.5 ros-kinetic-desktop-full install does not work. I have already automatically searched and chosen the best repository ( I am in Germany now, wokinr with autononomous car, so it choseed the de.fau...)

The return of the commands you suggest me are:

1- cat /etc/apt/sources.list.d/ros-latest.list deb xenial main

2) cat /etc/apt/sources.list | grep -v '#' deb xenial main restricted universe multiverse

deb xenial-updates main restricted universe multiverse

deb xenial partner deb-src xenial partner

deb xenial-security main restricted universe multiverse deb $(lsb_release -sc ...(more)

marcusvini178 gravatar imagemarcusvini178 ( 2019-10-08 02:42:26 -0500 )edit

The third return is :

3) apt list --installed | grep ros

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

cpp-5-aarch64-linux-gnu/now 5.4.0-6ubuntu1~16.04.9cross1 amd64 [Installiert,lokal] cuda-cross-aarch64-9-2/now 9.2.88-1 amd64 [Installiert,lokal] cuda-cublas-cross-aarch64-9-2/now 9.2.88-1 arm64 [Installiert,lokal] cuda-cudart-cross-aarch64-9-2/now 9.2.88-1 arm64 [Installiert,lokal] cuda-cufft-cross-aarch64-9-2/now 9.2.88-1 arm64 [Installiert,lokal] cuda-curand-cross-aarch64-9-2/now 9.2.88-1 arm64 [Installiert,lokal] cuda-cusolver-cross-aarch64-9-2/now 9.2.88-1 arm64 [Installiert,lokal] cuda-cusparse-cross-aarch64-9-2/now 9.2.88-1 arm64 [Installiert,lokal] cuda-driver-cross-aarch64-9-2/now 9.2.88-1 arm64 [Installiert,lokal] cuda-misc-headers-cross-aarch64-9-2/now 9.2.88-1 arm64 [Installiert,lokal] cuda-npp-cross-aarch64-9-2/now 9.2.88-1 arm64 [Installiert,lokal] cuda-nvgraph-cross-aarch64-9-2/now 9.2.88-1 arm64 [Installiert,lokal] cuda-n

marcusvini178 gravatar imagemarcusvini178 ( 2019-10-08 02:43:35 -0500 )edit

If you want to use the german ros package mirroir repository, use this command : sudo sh -c '. /etc/lsb-release && echo "deb $DISTRIB_CODENAME main" > /etc/apt/sources.list.d/ros-latest.list'

Actually you only use the ubuntu package german mirroir, which is good too but ros package will still download from (the default repo)

Can you delete the last line of your /etc/apt/sources.list ? It seem that this last line should not be here (the : deb $(lsb_release -sc) main" > /etc/apt/sources.list.d/ros )

Remember to sudo apt update after each change before trying to install.

also, please use the backtick ( ` ) when pasting command or triple backtick ( ``` ) when pasting muliline command or file, it make it easier to read :) some doc here

lmathieu gravatar imagelmathieu ( 2019-10-08 03:44:27 -0500 )edit

Thanks Imathies for your attention. I really need to solve this issue to begin working in the lab However it is not working: After realizing the steps you indicate I received the following message:

W: The repository " $(lsb_release Release" does not contain a release file. N: Data from such a repository cannot be authenticated and its use is potentially dangerous. N: See the apt-secure(8) manual page for more details on package vault creation and user configuration. E: Failed to fetch Expected entry "multivers/source/Sources" could not be found in release file (wrong entry in sources.list or malformed file). E: Failed to retrieve 404 Not Found [IP: 80] E: Failed to retrieve 404 Not Found [IP: 80]

marcusvini178 gravatar imagemarcusvini178 ( 2019-10-08 06:51:37 -0500 )edit

E: Failed to fetch 404 Not Found [IP: 80] E: Failed to retrieve 404 Not Found [IP: 80] E: Failed to retrieve 404 Not Found [IP: 80] E: Failed to fetch hash total does not match E: Failure to fetch 404 Not Found [IP: 80] E: Failed to fetch 404 Not Found [IP: 80] E: Failed to retrieve 404 Not Found [IP: 80] E: Failed to retrie

marcusvini178 gravatar imagemarcusvini178 ( 2019-10-08 06:52:34 -0500 )edit

Imatheus I think it is a repository "trust" issue. ┬░apt-secure(8)

Such is explained here

However I am not expert in computer sciences... I don t know how to make able the repositories to get the packages passing for the secutiry sytem, become it trustful, could you asssist me in realizing this?

Thanks in advance

marcusvini178 gravatar imagemarcusvini178 ( 2019-10-08 07:10:26 -0500 )edit

No problem about that,

Is your Ubuntu new ? You shouldn't have in your source.list

If your ubuntu is new (You just installed it and have no data in it), I recommend you to reinstall ubuntu again and follow the ROS installation again (Only if it's a new installation, because you will lose everything), I highly recommend you to do that if you can, as apt problem can be a pain to resolve.

if you have important data or can't reinstall, change your Ubuntu update center to Germany (system parameter > software update > Download from...) and please make sure that your /etc/apt/source.list look like this :

There should be no ROS mention and no "$(lsb_release"

And also, make sure that your /etc/apt/source.list.d/ros-lastest.list look like this :

lmathieu gravatar imagelmathieu ( 2019-10-08 07:22:13 -0500 )edit