gazebo is not starting and i have no errors

asked 2019-10-07 08:22:24 -0500

Em gravatar image

I want to roslaunch bb_8_gazebo main_empty.launch. I have installed bb_8_gazebo, but when i roslaunch it everything seems to be alright, but it's not starting. (I use ros-kinetic)

... logging to /home/emmanuel/.ros/log/6a6b14b2-e902-11e9-94b4-bcee7b17e4cc/roslaunch-emmanuel-X550LB-2421.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

xacro: Traditional processing is deprecated. Switch to --inorder processing!
To check for compatibility of your document, use option --check-order.
For more infos, see http://wiki.ros.org/xacro#Processing_Order
xacro.py is deprecated; please use xacro instead
started roslaunch server http://emmanuel-X550LB:35839/

SUMMARY
========

PARAMETERS
 * /head_camera/crop_decimate/decimation_x: 4
 * /head_camera/crop_decimate/decimation_y: 4
 * /head_camera/crop_decimate/queue_size: 1
 * /head_camera/head_camera_nodelet_manager/num_worker_threads: 2
 * /robot_description: <?xml version="1....
 * /robot_state_publisher/publish_frequency: 100.0
 * /rosdistro: kinetic
 * /rosversion: 1.12.14
 * /use_sim_time: True

NODES
  /head_camera/
    crop_decimate (nodelet/nodelet)
    head_camera_nodelet_manager (nodelet/nodelet)
  /
    cmd_vel_mux (topic_tools/mux)
    gazebo (gazebo_ros/gzserver)
    robot_state_publisher (robot_state_publisher/robot_state_publisher)
    urdf_spawner (gazebo_ros/spawn_model)
  /head_camera/depth_downsample/
    points_downsample (nodelet/nodelet)

auto-starting new master
process[master]: started with pid [2435]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 6a6b14b2-e902-11e9-94b4-bcee7b17e4cc
process[rosout-1]: started with pid [2448]
started core service [/rosout]
process[gazebo-2]: started with pid [2451]
process[robot_state_publisher-3]: started with pid [2456]
process[urdf_spawner-4]: started with pid [2457]
process[head_camera/head_camera_nodelet_manager-5]: started with pid [2461]
process[head_camera/crop_decimate-6]: started with pid [2464]
process[head_camera/depth_downsample/points_downsample-7]: started with pid [2465]
process[cmd_vel_mux-8]: started with pid [2466]
[ INFO] [1570453226.415500672]: Loading nodelet /head_camera/depth_downsample/points_downsample of type depth_image_proc/point_cloud_xyz to manager /head_camera/head_camera_nodelet_manager with the following remappings:
[ INFO] [1570453226.415596171]: /head_camera/depth_downsample/image_rect -> /image_raw
[ INFO] [1570453226.419081146]: Loading nodelet /head_camera/crop_decimate of type image_proc/crop_decimate to manager /head_camera/head_camera_nodelet_manager with the following remappings:
[ INFO] [1570453226.419299287]: /head_camera/camera/camera_info -> /head_camera/depth_registered/camera_info
[ INFO] [1570453226.419435346]: /head_camera/camera/image_raw -> /head_camera/depth_registered/image_raw
[ INFO] [1570453226.419601095]: /head_camera/camera_out -> /head_camera/depth_downsample
[ INFO] [1570453226.419561038]: waitForService: Service [/head_camera/head_camera_nodelet_manager/load_nodelet] has not been advertised, waiting...
[ INFO] [1570453226.421839310]: waitForService: Service [/head_camera/head_camera_nodelet_manager/load_nodelet] has not been advertised, waiting...
[ INFO] [1570453229.228147263]: Initializing nodelet with 2 worker threads.
SpawnModel script started
[INFO] [1570453234.475275, 0.000000]: Loading model XML from ros parameter
[INFO] [1570453234.478540, 0.000000]: Waiting for service /gazebo/spawn_urdf_model
[ INFO] [1570453235.502766055]: Finished loading Gazebo ROS API Plugin.
[ INFO] [1570453235.503771124]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...
[INFO] [1570453236.598994, 0.000000]: Calling service /gazebo/spawn_urdf_model
[INFO] [1570453236.812836, 0.000000]: Spawn status: SpawnModel: Successfully spawned entity
[urdf_spawner-4] process has finished cleanly
log file: /home/emmanuel/.ros/log/6a6b14b2-e902-11e9-94b4-bcee7b17e4cc/urdf_spawner-4*.log
[ INFO] [1570453237.365531537]: Camera Plugin: Using the 'robotNamespace' param: '/'
[ INFO] [1570453237.416189862]: Camera Plugin (ns = /)  <tf_prefix_>, set to ""
[ INFO] [1570453237.504395238]: Starting plugin DiffDrive(ns = //)
[ WARN] [1570453237.504555351]: DiffDrive(ns = //): missing <rosDebugLevel> default is na
[ INFO] [1570453237.949496051]: DiffDrive(ns = //): <tf_prefix> = 
[ WARN] [1570453237.949885853]: DiffDrive(ns = //): missing <publishWheelTF> default is false
[ WARN] [1570453237.949931058]: DiffDrive(ns = //): missing <publishWheelJointState> default is false
[ WARN] [1570453237.950322786]: DiffDrive(ns = //): missing <wheelAcceleration> default is 0
[ WARN] [1570453237.950362220 ...
(more)
edit retag flag offensive close merge delete

Comments

In the empty.launch file is using a custom world (tatooine.world). That world file contains a model you probably do not have in your system. Try to launch the empty world of gazebo and use the --verbose (<arg name="verbose" default="true"/>) flag to debug what is happening.

Weasfas gravatar imageWeasfas ( 2019-10-16 06:07:16 -0500 )edit