amd64.deb 404 not found (IP:91.189.88.31. 80) [closed]

asked 2019-10-04 12:34:26 -0500

marcusvini178 gravatar image

updated 2019-10-04 12:36:16 -0500

gvdhoorn gravatar image

I am trying to install the ROS-kinetic in Ubuntu 16.04.4 And I tried to install the required package with this command line:

sudo apt-get install cmake git libgtk2.0-dev pkg-config libavcodec-dev libavformat-dev libswscale-dev

However I get this error message:

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
pkg-config ist schon die neueste Version (0.29.1-0ubuntu1).
cmake ist schon die neueste Version (3.5.1-1ubuntu3).
git ist schon die neueste Version (1:2.7.4-0ubuntu1.6).
git wurde als manuell installiert festgelegt.
libavcodec-dev ist schon die neueste Version (7:2.8.15-0ubuntu0.16.04.1).
libswscale-dev ist schon die neueste Version (7:2.8.15-0ubuntu0.16.04.1).
libavformat-dev ist schon die neueste Version (7:2.8.15-0ubuntu0.16.04.1).
Die folgenden zusätzlichen Pakete werden installiert:
  debhelper dh-strip-nondeterminism gir1.2-gtk-2.0 libatk1.0-dev libcairo-script-interpreter2 libcairo2-dev libfile-stripnondeterminism-perl libfontconfig1-dev libfreetype6-dev
  libgdk-pixbuf2.0-dev libharfbuzz-dev libharfbuzz-gobject0 libmail-sendmail-perl libpango1.0-dev libpixman-1-dev libsys-hostname-long-perl libxcb-shm0-dev libxcomposite-dev
  libxft-dev po-debconf x11proto-composite-dev
Vorgeschlagene Pakete:
  dh-make libcairo2-doc libgtk2.0-doc libpango1.0-doc libmail-box-perl
Die folgenden NEUEN Pakete werden installiert:
  debhelper dh-strip-nondeterminism gir1.2-gtk-2.0 libatk1.0-dev libcairo-script-interpreter2 libcairo2-dev libfile-stripnondeterminism-perl libfontconfig1-dev libfreetype6-dev
  libgdk-pixbuf2.0-dev libgtk2.0-dev libharfbuzz-dev libharfbuzz-gobject0 libmail-sendmail-perl libpango1.0-dev libpixman-1-dev libsys-hostname-long-perl libxcb-shm0-dev
  libxcomposite-dev libxft-dev po-debconf x11proto-composite-dev
0 aktualisiert, 22 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen noch 956 kB von 6.977 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 37,7 MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] j
Fehl:1 http://archive.ubuntu.com/ubuntu xenial-security/main amd64 libfreetype6-dev amd64 2.6.1-0.1ubuntu2.3
  404  Not Found [IP: 91.189.88.31 80]
Fehl:1 http://archive.ubuntu.com/ubuntu xenial-security/main amd64 libfreetype6-dev amd64 2.6.1-0.1ubuntu2.3
  404  Not Found [IP: 91.189.88.31 80]
E: Fehlschlag beim Holen von http://archive.ubuntu.com/ubuntu/pool/main/f/freetype/libfreetype6-dev_2.6.1-0.1ubuntu2.3_amd64.deb  404  Not Found [IP: 91.189.88.31 80]

E: Einige Archive konnten nicht heruntergeladen werden; vielleicht »apt-get update« ausführen oder mit »--fix-missing« probieren?

I have done the command suggested, looked in my source.list.d and there is not server lookin for arm64 or amd64... I changed the sorce.list to look in universe and multiverse and partners servers but had no success. Could someone help me?

Thanks in advance

edit retag flag offensive reopen merge delete

Closed for the following reason question is off-topic or not relevant. Please see http://wiki.ros.org/Support for more details. by gvdhoorn
close date 2019-10-04 12:37:31.522554

Comments

1

Looking at the error message it seems to complain about a regular Ubuntu package:

Fehl:1 http://archive.ubuntu.com/ubuntu xenial-security/main amd64 libfreetype6-dev amd64 2.6.1-0.1ubuntu2.3

not a ROS package.

As such I don't believe this is a ROS related question, and would suggest you post this on a more appropriate forum, such as Ask Ubuntu.


Edit: I've also closed your question because of this. If it turns out this is a ROS problem, we can always re-open.

gvdhoorn gravatar imagegvdhoorn ( 2019-10-04 12:37:20 -0500 )edit
1

I just noticed this:

I am trying to install the ROS-kinetic in Ubuntu 16.04.4 And I tried to install the required package with this command line:

sudo apt-get install cmake git libgtk2.0-dev pkg-config libavcodec-dev libavformat-dev libswscale-dev

the official installation tutorial does not tell you to do that. How did you determine that you needed to run that command?

gvdhoorn gravatar imagegvdhoorn ( 2019-10-04 12:40:05 -0500 )edit