ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

kinect v1 problems

asked 2019-09-13 16:28:08 -0600

elgarbe gravatar image

updated 2019-09-14 05:25:41 -0600

gvdhoorn gravatar image

Hi, I have a kinnect v1 connected to my desktop pc running lubuntu 16.04 I've installed freenect-launch and openni-launch package.

I run

roslaunch openni_launch openni.launch depth_registration:=true


roslaunch freenect_launch freenect.launch depth_registration:=true

on a second terminal I run

rostopic hz /camera/rgb/image_raw

and start getting 30 hz measurement. On a third terminal I run

rostopic hz /camera/depth_registered/image

and once I get to measurement message I get "no new messages" on both, 2nd and 3rd terminal. I don't get any message on 1st terminal, but I don't get any messages. I have to close all laucnhs unplug kinnect and replug, then relaunch everything, but the same test get the same result.

Is there a way to test my kinnect cammera on linux or windows? I would like to know if it is a sensor problem or if it is a driver problem.


edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2019-09-14 14:33:08 -0600 gravatar image

First, it is recommended to use only one of the libraries/drivers, and I suggest libfreenect.

So try to use only libfreenect and view in RVIZ to test the kinect.

Launch the freenect and open the RVIZ with rviz.

After open RVIZ:

  1. Fixed Frame: camera_link
  2. Add in "add" other visualization types: axes and point cloud
  3. Set Topic = / camera / depth_registered / points
edit flag offensive delete link more


Ok, I remove all freenect and openni driver. Then just install ros-kinect-freenect-launch and try what you suggest, That works ok. But freenect randomly die after a couple of minutes

elgarbe gravatar image elgarbe  ( 2019-09-14 20:55:30 -0600 )edit

You remove all freenect driver? I dont know if it is necessary but I use at least libfreenect-dev and ros-kinetic-freenect-launch when seeing rviz. gravatar image  ( 2019-09-15 13:41:25 -0600 )edit

Hi , I'm having a similar issue , I'm running windows 10 and inside windows 10 I'm running Virtual Box (Ubuntu 16.04 Virtual Machine), I ran this roslaunch freenect_launch freenect.launch depth_registration:=true and also this one rostopic hz /camera/depth_registered/image and I get the same thing 'no new messages' , after open RVIZ:...., I have added in the 3 parameters and still I see nothing, please help ? thank you !

bot777 gravatar image bot777  ( 2020-09-22 03:21:03 -0600 )edit

Question Tools



Asked: 2019-09-13 16:28:08 -0600

Seen: 478 times

Last updated: Sep 14 '19