[Ros 2] depth_image_proc

asked 2019-08-27 14:07:54 -0500

zipp39 gravatar image

updated 2019-08-28 02:43:44 -0500

gvdhoorn gravatar image

OS: Windows 10 ROS Version- ROS 2 Dashing patch 1

Hi! I am trying to use the depth_image_proc library. I am trying to call the launch file for point_cloud_xyzi_radial.launch.py but I am getting an error that api_composition and api_composition_cli Does not Exist (Yes, I commented out the intel realsense line). ROS 2 image_pipeline/depth_image_proc).

This is the error I receive right before it shuts down.

[ERROR] [launch]: Caught exception in launch (see debug for traceback): executable 'api_composition' not found on the libexec directory 'C:\dev\ros2\lib\composition'

Does anyone know how to properly launch this node? I am using components and containers for my projects currently, and even tried to make this node the same. My prediction is the api_composition_cli stuff is all out dated. I just need to be able to launch this node!!

Edit:

I also tried making it an rclcpp_component and I got an Exception thrown in the launch saying "undefined Reference"

THank you

edit retag flag offensive close merge delete

Comments

Could you please tag questions with the appropriate tags? In this case: Windows10 and RosOnWindows? That will both associate it with other ROS-on-Windows questions as well as alert interested board members to you posting them.

gvdhoorn gravatar imagegvdhoorn ( 2019-08-28 02:43:30 -0500 )edit