Ask Your Question
0

Error while adding UR5 manipulator on Husky and ROS Kinetic, using "husky_manipulation" package [SOLVED]

asked 2019-07-26 15:47:58 -0500

updated 2019-08-02 08:51:36 -0500

[SOLVED]

I'm trying to add a UR5 manipulator on Husky, which is supported only in Indigo, and I'm using Kinetic. But, I found the package "husky_manipulation" on Github ([https://github.com/husky/husky_manipu...]) which apparently make possible to run UR5 on Kinetic. So, I'm following the tutorial in this link, and after modifying the URDF file and starting the simulation, I'm getting this error:

felipe@felipe-dq77pro:~/husky_ws$ roslaunch husky_gazebo husky_playpen_mod.launch ... logging to /home/felipe/.ros/log/4a02330c-afe3-11e9-b776-a0f3c186ea4a/roslaunch-felipe-dq77pro-12050.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

resource not found: ur_description
ROS path [0]=/opt/ros/kinetic/share/ros
ROS path [1]=/home/felipe/husky_ws/src
ROS path [2]=/opt/ros/kinetic/share None
when processing file: /home/felipe/husky_ws/src/husky_manipulation/husky_ur_description/urdf/husky_ur5_description.urdf.xacro
included from: /home/felipe/husky_ws/src/husky/husky_description/urdf/husky.urdf.xacro
while processing /home/felipe/husky_ws/src/husky/husky_gazebo/launch/spawn_husky.launch:
while processing /home/felipe/husky_ws/src/husky/husky_control/launch/control.launch:
while processing /home/felipe/husky_ws/src/husky/husky_description/launch/description.launch:
Invalid <param> tag: Cannot load command parameter [robot_description]: command [/opt/ros/kinetic/lib/xacro/xacro '/home/felipe/husky_ws/src/husky/husky_description/urdf/husky.urdf.xacro'     --inorder     robot_namespace:=/     laser_enabled:=false     kinect_enabled:=true     urdf_extras:=/home/felipe/husky_ws/src/husky/husky_description/urdf/husky.urdf.xacro     ] returned with code [2]. 

Param xml is <param command="$(find xacro)/xacro '$(find husky_description)/urdf/husky.urdf.xacro'     --inorder     robot_namespace:=$(arg robot_namespace)     laser_enabled:=$(arg laser_enabled)     kinect_enabled:=$(arg kinect_enabled)     urdf_extras:=$(arg urdf_extras)     " name="robot_description"/>
The traceback for the exception was written to the log file

And my husky.urdf.xacro file after inluding the UR5 description is:

<?xml version="1.0"?>

<robot name="husky" xmlns:xacro="http://ros.org/wiki/xacro">

  <xacro:arg name="laser_enabled" default="false" />
  <xacro:arg name="laser_xyz" default="$(optenv HUSKY_LMS1XX_XYZ 0.2206 0.0 0.00635)" />
  <xacro:arg name="laser_rpy" default="$(optenv HUSKY_LMS1XX_RPY 0.0 0.0 0.0)" />

  <xacro:arg name="kinect_enabled" default="false" />
  <xacro:arg name="kinect_xyz" default="$(optenv HUSKY_KINECT_XYZ 0 0 0)" />
  <xacro:arg name="kinect_rpy" default="$(optenv HUSKY_KINECT_RPY 0 0.18 3.14)" />

  <xacro:property name="husky_bumper_extend" value="$(optenv HUSKY_FORWARD_BUMPER_EXTEND 0)" />

  <xacro:arg name="robot_namespace" default="/" />
  <xacro:arg name="urdf_extras" default="empty.urdf" />

  <!-- Included URDF/XACRO Files -->
  <xacro:include filename="$(find husky_description)/urdf/decorations.urdf.xacro" />
  <xacro:include filename="$(find husky_description)/urdf/wheel.urdf.xacro" />

  <xacro:include filename="$(find husky_description)/urdf/accessories/kinect_camera.urdf.xacro"/>
  <xacro:include filename="$(find husky_description)/urdf/accessories/sick_lms1xx_mount.urdf.xacro"/>
  <xacro:include filename="$(find husky_description)/urdf/accessories/sensor_arch.urdf.xacro"/>
  <xacro:include filename="$(find husky_ur_description)/urdf/husky_ur5_description.urdf.xacro" /> 

  <xacro:property name="M_PI" value="3.14159"/>

  <!-- Base Size -->
  <xacro:property name="base_x_size" value="0.98740000" />
  <xacro:property name="base_y_size" value="0.57090000" />
  <xacro:property name="base_z_size" value="0 ...
(more)
edit retag flag offensive close merge delete

Comments

1

Just so you know, you don't have to write

[SOLVED]

in your question or title. Having an answer marked as "correct" (with the check mark) shows that it has been solved.

jayess gravatar imagejayess ( 2019-08-02 12:24:24 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-07-28 12:34:24 -0500

gvdhoorn gravatar image

updated 2019-07-28 12:36:14 -0500

resource not found: ur_description

this seems to suggest you don't have the ur_description package installed.

That package is listed as a dependency of husky_ur_description here so I'm wondering how you made sure you had all the required dependencies installed for that package before trying to build and use it. Did you run rosdep?

In any case: if the output of dpkg -l | grep ur-description is empty, try installing it with sudo apt install ros-kinetic-ur-description and try again.

edit flag offensive delete link more

Comments

Thanks, man. It was so simple... I didn't see that. It's working now, I will just need to adjust my urdfs because Husky got unstable.

xxros gravatar imagexxros ( 2019-07-30 16:02:55 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-07-26 15:47:58 -0500

Seen: 45 times

Last updated: Aug 02