Ask Your Question
0

apt update fails/ cannot install pkgs even after updating keys

asked 2019-07-25 04:13:12 -0500

matteolucchi gravatar image

While trying to run: apt updateI encountered the same problem described in https://answers.ros.org/question/3250...

After following what @gvdhoorn suggested and trying to run apt update again, I get the following error:

Get:31 http://packages.ros.org/ros/ubuntu xenial/main amd64 Packages [3.150 kB]
Err:31 http://packages.ros.org/ros/ubuntu xenial/main amd64 Packages
Writing more data than expected (3154295 > 3149706) [IP: 64.50.236.52 80]

I tried this on two different PCs with Ubuntu 16.04 and ROS Kinetic installed. Is this something related to the repository having troubles or something wrong on my machine ? Does anyone else have the same problem?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-07-26 10:45:54 -0500

matteolucchi gravatar image

What solved the issue was to run sudo apt-get clean before running sudo apt-get update

edit flag offensive delete link more

Comments

so if you problem is solved just close the questen

duck-development gravatar imageduck-development ( 2019-07-26 10:56:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-07-25 04:13:12 -0500

Seen: 41 times

Last updated: Jul 26