ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

Autoware Mission Planning, Client has wrong datatype version: datatype/md5sum

asked 2019-07-18 10:54:14 -0500

hdossaji94 gravatar image

updated 2022-03-20 09:42:19 -0500

lucasw gravatar image

When I try to launch mission planning node for San Francisco data launch files, I end up getting this error:

Error: Client [/rivz_1563460306167327804] wants topic /local_trajectories to have datatype/md5sum [visualization_msgs/MarkerArray/d155b9ce5188fbaf89745847fd5882d7], but our version has [autoware_msgs/LaneArray/23abb100bdfa4ee58530bb628c974c2a]. Dropping connection.

Does anybody know what the problem is?

Thank you

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2019-07-18 14:58:13 -0500

updated 2019-07-18 15:04:07 -0500

It means they were compiled with different versions of the message files. When the message files are compiled they make a MD5 hash in case those message definitions change to make sure they're able to be decoded correctly by the receiver. You need to have both programs using the right set of definitions installed.

Edit: More info, sorry I scanned over the types and missed the fact they are literally different messages.

Ok, so what you're trying to do here is expose a topic of type autoware_msgs/LaneArray on the topic /local_trajectories. You've created the data vis plugin for local_trajectories to have type MarkerArray, which is not LaneArray. Your issue is that you have the wrong messages being broadcast on that topic. You need to create the correct plugin visualization to see the LaneArray (does autoware provide?)

edit flag offensive delete link more


Thanks for the quick response! Would you mind giving me some insight into the steps involved to do this?

hdossaji94 gravatar image hdossaji94  ( 2019-07-18 15:00:41 -0500 )edit

See update in answer, you're publishing the wrong message type on that topic to be visualized as a MarkerArray.

stevemacenski gravatar image stevemacenski  ( 2019-07-18 15:04:31 -0500 )edit

answered 2020-05-27 22:17:16 -0500

SenRamakri gravatar image

updated 2022-03-20 09:43:46 -0500

lucasw gravatar image

I ran into the same problem and below is how I resolved it. The problem is caused by Rviz config file having the wrong configuration for local_trajectories.

With the latest version of Autoware, topic for Rviz is named /local_trajectories_gen_rviz(see here: So open your rviz config file and find the entry for local_trajectories and change it to local_trajectories_gen_rviz. This should resolve the above error.

edit flag offensive delete link more


Thank you! This has solved my issue.

xqr gravatar image xqr  ( 2020-12-01 05:24:33 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2019-07-18 10:54:14 -0500

Seen: 861 times

Last updated: Mar 20 '22