Ask Your Question
0

Installing Openrave Package

asked 2012-04-27 21:58:02 -0600

bcddivad gravatar image

I tried to install openrave package for ros-electric on my Ubuntu 10.04.

  svn co https://jsk-ros-pkg.svn.sourceforge.net/svnroot/jsk-ros-pkg/trunk/openrave_planning

I tried to rosmake the package but it turned out there's some error. So I then downloaded the following packages

posedetection_msgs

  svn co https://jsk-ros-pkg.svn.sourceforge.net/svnroot/jsk-ros-pkg/trunk/jsk_common/posedetection_msgs

parallel_util

  svn co https://jsk-ros-pkg.svn.sourceforge.net/svnroot/jsk-ros-pkg/trunk/jsk_common/parallel_util

I rosmake those packages and re-rosmake the openrave_planning package. However, new error occurred

  [rospack] couldn't find package [soqt]
  echo "prefix=/opt/ros/electric/stacks/bullet\n\
  libdir=/opt/ros/electric/stacks/bullet/build/include\n\
  includedir=/opt/ros/electric/stacks/bullet/lib\n\
  \n\
  Name: Bullet\n\
  Description: Bullet as built by ROS\n\
  Version: 2.74\n\
  Libs: -L/opt/ros/electric/stacks/bullet/lib -Wl,-rpath,/opt/ros/electric/stacks/bullet/lib -lBulletDynamics -lBulletCollision -lLinearMath        \n\
  CFlags: -I/opt/ros/electric/stacks/bullet/include -DBT_USE_DOUBLE_PRECISION -DBT_EULER_DEFAULT_ZYX      " > bullet.pc
  cd `rospack find openrave` && rm -rf share/openrave include/rave include/openrave-core.h share/openrave0.3/openravepy && rm -f build/CMakeCache.txt && export PATH="/bin:/home/bcddivad/code/ros/openrave/openrave_planning/ns-allinone-2.35/tcl8.5.10/unix:/home/bcddivad/code/ros/openrave/openrave_planning/ns-allinone-2.35/tk8.5.10/unix:/home/bcddivad/code/ros/openrave/openrave_planning/ns-allinone-2.35/bin:/opt/ros/electric/ros/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games" && export PKG_CONFIG_PATH=":`rospack find openrave`" && mkdir -p build && cd build && BOOST_INCLUDEDIR= BOOST_LIBRARYDIR=/usr/lib cmake -DCMAKE_INSTALL_PREFIX=`rospack find openrave` -DCMAKE_BUILD_TYPE=RelWithDebInfo -DODE_USE_MULTITHREAD=ON -D_odeconfig_cflags:STRING="-I/opt/ros/electric/stacks/physics_ode/opende/opende/include -DdDOUBLE -I/opt/ros/electric/stacks/physics_ode/opende/threadpool  " -D_odeconfig_lflags:STRING="-Wl,-rpath,/opt/ros/electric/stacks/physics_ode/opende/opende/lib -Wl,-rpath,/opt/ros/electric/stacks/physics_ode/opende/opende/lib -L/opt/ros/electric/stacks/physics_ode/opende/opende/lib -lode  " ../openrave_svn && export PARALLEL_JOBS=ROS_PARALLEL_JOBS && make -l8
  CMake Error: The source directory "/home/bcddivad/code/ros/openravecode/openrave/openrave_svn" does not appear to contain CMakeLists.txt.
  Specify --help for usage, or press the help button on the CMake GUI.

How can I solve this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-05-01 08:33:48 -0600

You probably should install libsoqt4-dev, go to synaptic and try to install this package!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-04-27 21:58:02 -0600

Seen: 941 times

Last updated: May 01 '12