ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

LSD-SLAM double free or corruption

asked 2019-07-16 07:55:21 -0600

MrMinemeet gravatar image

updated 2022-01-22 16:10:00 -0600

Evgeny gravatar image


I'm trying to run the LSD-SLAM by using ROS-Melodic and Ubuntu 18.04. It compiled fine with no errors but when trying to start the lsd_slam_core using this comand: rosrun lsd_slam_core live_slam /image:=/camera/image_raw _calib:=src/lsd_slam/calibration_params it throws a message and then stops.

This is the message I get:
double free or corruption (out)
Aborted (core dumped)

I'm not sure where it dumps the core but I'll attach it if someone could tell me. I found this Issue on Github which more or less handles the same error, and there they recommend using another version of Eigen. I installed multiple versions but it didn't run, and I always got the same eror.

Hope someone can help me.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted

answered 2019-07-18 07:54:00 -0600

MrMinemeet gravatar image

Ok fixed it myself :D it worked I as stated in the comment on the other answer I wasn't able to compile it on another version because g2o didn't like eigen 3.2.5. But when only using Eigen 3.2.5 on catkin_make for LSD_SLAM without a problem.
Here's what I did. I just sed the variable EIGEN3_INCLUDE_DIR to the path of the downloaded 3.2.5 one line above the include_directories
image description

hope this helps someone.

edit flag offensive delete link more


This worked for me. Thanks a lot!

bas gravatar image bas  ( 2019-10-30 04:19:24 -0600 )edit

answered 2019-07-16 08:43:22 -0600

How have you installed multiple versions of Eigen? The fix described in that github issue, is to remove all versions installed using the package manager then download and install exactly version 3.2.5 from the repository directly. You'll then need to re-compile LSD-SLAM for it to incorporate the newly installed version of Eigen. It is a header only library not a shared object so any code that isn't re-compiled will still include the old version.

Let us know how you get on with this.

edit flag offensive delete link more


Might have missexplained that a bit. I mennt installing a version, compiling and checking if it worked, when not I uninstalled it and installed another version. Sadly installing a special version didin't work because apperently it only compiles successfully when having libeigen3-dev from apt manager installed.

MrMinemeet gravatar image MrMinemeet  ( 2019-07-18 07:21:33 -0600 )edit

You might need to get your hands dirty to get LSD SLAM to compile with that version. Possibly remove the dependency on libeigen3-dev from the package and ensure that the right version of the Eigen headers can be found.

PeteBlackerThe3rd gravatar image PeteBlackerThe3rd  ( 2019-07-18 07:31:43 -0600 )edit

Hi Is this issue solved for you guys ? I am still facing the issues. I tried the fix of downloading the eigen library 3.2.5. I didnt build it but stored in a local folder and then recompiled the lsd_slam with catkin_make. It it still throwing the error of double free or corruption (out) Aborted (core dumped) can you help me to solve it ?

thanks in advance

Vignesh_93 gravatar image Vignesh_93  ( 2021-01-01 10:02:13 -0600 )edit

Question Tools

1 follower


Asked: 2019-07-16 07:55:21 -0600

Seen: 1,733 times

Last updated: Jul 18 '19