Ask Your Question
0

Setting octomap resolution doesn't work

asked 2019-07-15 09:24:39 -0500

Krebsileinchen gravatar image

I am working with ROS kinetic and implemented perception with octomap like described in http://docs.ros.org/kinetic/api/movei... . However, when I am changing octomap_resolution in my launch file, the generated octomap doesn't change the resolution. It looks like it's always using the default value of 0.05. I checked the value with rosparam get just after starting the launch file and after receiving the point cloud. At both times it shows the value I've set but the result shown in RViz still does use the default value. Any ideas where I am wrong or what I could check to get some ideas? Thanks in advance!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-07-22 09:32:57 -0500

Krebsileinchen gravatar image

updated 2019-09-18 04:18:37 -0500

I found the solution. I had to set the parameter /move_group/octomap_resolution instead of only octomap_resolution.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-07-15 09:24:39 -0500

Seen: 61 times

Last updated: Sep 18