Ask Your Question
0

Raspberry camera module not working on Raspberry Pi 3 B

asked 2019-07-14 01:58:59 -0500

Hi, I have Raspberry pi 3 B module with Linux based Raspbian Image OS on it.But when I connect it with raspberry pi camera module v2.1 , it does not work. It does not show image during rqt_image_view on Remote PC. I am using rosrun raspicam_node raspicam_node command for running camera through ROS. Please guide me if there is some solution.

H/w and s/w specifications:- Remote pc : Ubuntu 16.04, ROS Kinetic

Raspberry pi 3 B module with Linux based Raspbian Image OS.

Raspberry pi camera v2.1

Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-07-14 03:05:47 -0500

indraneel gravatar image

updated 2019-07-14 03:06:22 -0500

So, out of the top of my head,

  • have you tried using picamera (https://picamera.readthedocs.io/en/re...) on the raspberry pi itself with the same configuration? Its a good idea to test if the hardware is working with native libraries outside of ROS before you try ROS packages. If the camera isnt working outside of ROS then there is no way it will work with raspicam_node

    • Since you are using a remote PC, you should ensure your ROS multiple machines set up is working properly, publish a simple float topic on raspberry pi and see if you can echo it from remote PC
  • If step one and two is working then before using rqt_image_view on remote PC it is a good idea to rostopic echo the raw camera feed first and check if the topic is not empty.

Hope this helps.

edit flag offensive delete link more

Comments

Hi, As you mentioned I even tried to do it without ROS using following command raspistill -o image.jpg to capture images,but it still did not start the camera ,instead error came which told that It says no camera detected. And I even tried it on another raspberry camera module I had ,the error remained same. So I am not understanding if the camera has defect or the raspberry pi b camera port on which we attach our camera is at fault.

Thanks

rutujaharidas gravatar imagerutujaharidas ( 2019-07-14 03:20:20 -0500 )edit

Alright, then I am afraid this is not a ROS related problem, you could use other forums like stack exchange to get better accurate help on this issue.

Its hard to say whether the port has an issue or if there is a software problem. Just for the sake of it you could this thread for troubleshooting : https://raspberrypi.stackexchange.com...

Hope you solve this problem soon. Good luck.

indraneel gravatar imageindraneel ( 2019-07-14 09:40:01 -0500 )edit
1

Have you included the camera in the Pi Config? It doesn't work out of the box.

billy gravatar imagebilly ( 2019-07-15 14:50:42 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-07-14 01:58:59 -0500

Seen: 15 times

Last updated: Jul 14