Can't start roscore on Windows 10 installation

asked 2019-07-09 15:41:52 -0500

PeterVB gravatar image

updated 2019-07-09 15:46:58 -0500

gvdhoorn gravatar image

This is what I get. Help would be appreciated.

 **********************************************************************
** Visual Studio 2017 Developer Command Prompt v15.0
** Copyright (c) 2017 Microsoft Corporation
**********************************************************************

C:\Windows\System32>roscore
Traceback (most recent call last):
  File "C:\opt\ros\melodic\x64\bin\roscore", line 36, in <module>
    from rosmaster.master_api import NUM_WORKERS
  File "C:\opt\ros\melodic\x64\lib\site-packages\rosmaster\__init__.py", line 35, in <module>
    from .main import rosmaster_main
  File "C:\opt\ros\melodic\x64\lib\site-packages\rosmaster\main.py", line 43, in <module>
    import rosmaster.master
  File "C:\opt\ros\melodic\x64\lib\site-packages\rosmaster\master.py", line 47, in <module>
    import rosmaster.master_api
  File "C:\opt\ros\melodic\x64\lib\site-packages\rosmaster\master_api.py", line 72, in <module>
    from rosmaster.util import xmlrpcapi
  File "C:\opt\ros\melodic\x64\lib\site-packages\rosmaster\util.py", line 48, in <module>
    from defusedxml.xmlrpc import monkey_patch
ImportError: No module named defusedxml.xmlrpc

C:\Windows\System32>
edit retag flag offensive close merge delete

Comments

Thanks for the quick response. For the first edit (...rosmaster_init_py) which file would I edit? I have not found NUM_WORKERS or code in rosmaster_main with the error.

For the second issue, I have tried to choco install defused.xmlrpc but it is not at the default location.

PeterVB gravatar imagePeterVB ( 2019-07-09 16:29:45 -0500 )edit

@PeterVB, if you ever hit any problems of some dependencies not being installed correctly, you can run c:\opt\ros\melodic\x64\setup.bat to source the ROS install, and then run rosdep install --from-paths c:\opt\ros\melodic\x64\ --ignore-src -r -y to let the tool examine and reinstall all the required libraries again.

Sean Yen gravatar imageSean Yen ( 2019-07-10 12:46:22 -0500 )edit

Yah, so none of that actually worked at all. I am still unable to use ROS.

Frustrating.

PeterVB gravatar imagePeterVB ( 2019-08-01 13:55:43 -0500 )edit