ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

URDF/COLLADA file is not a valid robot model | no name given for the robot | Universal Robots (UR)

asked 2019-07-01 22:13:19 -0600

Vini71 gravatar image

I have dowloaded the Universal Robots (UR3, UR5 and UR10) from:

I am trying to load the Urdf | xacro file in Moveit setup assistant...However I cannot load the robot

The error msg in Movelt Apl is "URDF/COLLADA file is not a valid robot model."

And the terminal returns me the following message: "No name given for the robot"

I followed the "tutorial" given by the link above...I executed the commands:

rosdep update....rosdep install rosdistro etc... and source ...devel/bash..

I also dowloaded the package with the Abb robots....and there was no problem in load them in Moveit. However I need a robot with ee_effector to follow the tutorial from qbotics...Lenthin Joseph...form the book Mastering ROS... anyway when I was finishing the setup from Abb robot moveit stopped and a shadow color stopped to work, I don't know why. I would like to load the ur10 robot!

obs: I have already looked the answers similar to this issue in Forum, however they did not adressed my case!

Could someone help me to find the error?

Thanks in advance

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2019-07-01 23:00:54 -0600

gvdhoorn gravatar image

The answer you've posted is actually not the answer.

Those files are used by thousands of people and they are correct as-is.

The cause of your problem is that you've selected the wrong file to load.

Instead of loading ur10e.urdf.xacro, you should load the ur10e_robot.urdf.xacro file.

The former only defines the macro, but doesn't instantiate it. The latter is a top-level xacro that includes the appropriate files and then also instantiates the model.

Loading a file that only defines a macro will result in an empty file after the MSA tries to load it, hence the error.

edit flag offensive delete link more

answered 2019-07-01 22:42:52 -0600

Vini71 gravatar image

updated 2019-07-01 22:56:45 -0600

gvdhoorn gravatar image

I am sorry guys I found the problem!!!

I tried exhaustively solve the issue....

Maybe help someone too: The problem is in the urdf.xacro files which is the robot_model_description...

In the first line on the headers, the authors wrote:

<?xml version="1.0"?>
<robot xmlns:xacro=""
       name="ur10e" >

When they should write:

<?xml version="1.0"?>
<robot xmlns:xacro="">
<xacro:include filename="ur10e">

When I implemented the change below, the moveit_assistant worked well and load the urdf model!!!

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2019-07-01 22:13:19 -0600

Seen: 3,615 times

Last updated: Jul 01 '19