Ask Your Question
0

Schunk LWA4P initialization problem with ros_canopen

asked 2019-06-13 05:00:58 -0500

verena gravatar image

updated 2019-06-24 09:48:15 -0500

Hi,

I try to launch a LW4P with ros_canopen. I use ROS kinetic and a PCAN-USB Pro adapter. I already tried out the suggestions on similar problems on ROS answers and on GitHub but unfortunately my issue remains.

First I setup my CAN interface

$ ~/catkin-pem-robot-v2# sudo ip link set can0 down
$ ~/catkin-pem-robot-v2# sudo ip link set can0 up type can bitrate 500000
$ ~/catkin-pem-robot-v2# sudo ip link set can0 up txqueuelen 20

Then I launch the robot

$ ~/catkin-pem-robot-v2$ roslaunch pem_robot pem_robot_v3.launch 
WARNING: Could not change permissions for folder [/home/verena/.ros/log/c8077c0a-8dbd-11e9-b028-ac7ba18b123a], make sure that the parent folder has correct permissions.
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

xacro: Traditional processing is deprecated. Switch to --inorder processing!
To check for compatibility of your document, use option --check-order.
For more infos, see http://wiki.ros.org/xacro#Processing_Order
xacro.py is deprecated; please use xacro instead
started roslaunch server http://verena-CELSIUS-H730:33227/

SUMMARY
========

CLEAR PARAMETERS
 * /lh_arm/driver/

PARAMETERS
 * /joint_state_mixer/robot_description: <?xml version="1....
 * /lh_arm/driver/bus/device: can0
 * /lh_arm/driver/defaults/dcf_overlay/604Csub1: 1
 * /lh_arm/driver/defaults/dcf_overlay/604Csub2: 24000
 * /lh_arm/driver/defaults/dcf_overlay/6060: 1
 * /lh_arm/driver/defaults/eds_file: config/Schunk_0_6...
 * /lh_arm/driver/defaults/eds_pkg: pem_arm_lh
 * /lh_arm/driver/defaults/vel_to_device: rint(rad2deg(vel)...
 * /lh_arm/driver/name: arm
 * /lh_arm/driver/nodes/lh_arm_0_joint/id: 10
 * /lh_arm/driver/nodes/lh_arm_1_joint/id: 5
 * /lh_arm/driver/nodes/lh_arm_2_joint/id: 6
 * /lh_arm/driver/nodes/lh_arm_3_joint/id: 3
 * /lh_arm/driver/nodes/lh_arm_4_joint/id: 4
 * /lh_arm/driver/nodes/lh_arm_5_joint/id: 7
 * /lh_arm/driver/nodes/lh_arm_6_joint/id: 8
 * /lh_arm/driver/sync/interval_ms: 50
 * /lh_arm/driver/sync/overflow: 0
 * /lh_arm/hardware_control_loop/loop_hz: 125
 * /lh_arm/hardware_interface/joints: ['lh_arm_0_joint'...
 * /lh_arm/joint_state_controller/publish_rate: 50
 * /lh_arm/joint_state_controller/type: joint_state_contr...
 * /lh_arm/pos_based_pos_traj_controller_arm_lh/joints: ['lh_arm_0_joint'...
 * /lh_arm/pos_based_pos_traj_controller_arm_lh/publish_rate: 50
 * /lh_arm/pos_based_pos_traj_controller_arm_lh/required_drive_mode: 7
 * /lh_arm/pos_based_pos_traj_controller_arm_lh/type: position_controll...
 * /lh_arm/robot_description: <?xml version="1....
 * /robot_description: <?xml version="1....
 * /rosdistro: kinetic
 * /rosversion: 1.12.14

NODES
  /lh_arm/
    driver (canopen_motor_node/canopen_motor_node)
    joint_state_publisher (joint_state_publisher/joint_state_publisher)
    robot_initialization (rosservice/rosservice)
    ros_control_controller_spawner (controller_manager/spawner)
  /
    joint_state_mixer (pem_robot/joint_state_mixer.py)
    robot_state_publisher (robot_state_publisher/robot_state_publisher)

auto-starting new master
process[master]: started with pid [6027]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to c8077c0a-8dbd-11e9-b028-ac7ba18b123a
process[rosout-1]: started with pid [6052]
started core service [/rosout]
process[lh_arm/driver-2]: started with pid [6071]
process[lh_arm/ros_control_controller_spawner-3]: started with pid [6072]
process[lh_arm/joint_state_publisher-4]: started with pid [6073]
process[lh_arm/robot_initialization-5]: started with pid [6074]
process[joint_state_mixer-6]: started with pid [6083]
process[robot_state_publisher-7]: started with pid [6093]
[ INFO] [1560418188.416560376]: Using fixed control period: 0.050000000
[INFO] [1560418188.461155]: Controller Spawner: Waiting for service controller_manager/load_controller
[ INFO] [1560418188.509712642]: Initializing XXX
[ INFO] [1560418188.510056097]: Current state: 1 device error: system:0 internal_error: 0 (OK)
[ INFO] [1560418188.510289199]: Current state: 2 device error: system:0 internal_error: 0 (OK)
EMCY: 8A#2232257400000000
EMCY: 85#223225740000803F
EMCY: 86#2232257400001C42
[ INFO] [1560418199.018367789]: Current state: 2 device error: system:125 internal_error: 0 (OK)
[ INFO] [1560418199.018453747]: Current state: 0 device error: system:125 internal_error: 0 (OK)
[ INFO ...
(more)
edit retag flag offensive close merge delete

Comments

Hello , did you try to start just the driver "canopen_motor_node" and manualy spawn your controller ? with rqt if it's easyer.

Is your candump complete ? I don't see node many node state in you candump but, as log indicates a controller interface not found probleme.

I think it migh help if you send your configuration file *controller.yaml and canopen_chaine_node.yaml etc.

adrienH gravatar imageadrienH ( 2019-06-20 01:52:40 -0500 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2019-06-21 10:15:10 -0500

Mathias Lüdtke gravatar image
EMCY: 8A#2232257400000000
EMCY: 85#223225740000803F
EMCY: 86#2232257400001C42

If I am not mistaken, this is an under-voltage emergency alert (0x3222). Please check your power supply.

edit flag offensive delete link more

Comments

thank you! Yes apparently power supply was one issue. The EMCY message have disappeared now. However, the other error messages are remaining and I am still not able to launch the LWA4P. I encountered some strange things: It seems that some of my CAN modules are not recognized at all. At the startup candump can0 only gives me the following can0 705 [1] 00 can0 706 [1] 00 can0 70A [1] 00 If I only launch the recognized nodes without the non-recognized nodes, I can move the recognized nodes as expected.

But what could be the reason for not recognizing some of my modules?

Thank you in advance!

verena gravatar imageverena ( 2019-06-24 09:37:32 -0500 )edit
0

answered 2019-06-25 07:09:27 -0500

verena gravatar image

I just solved my problem.

I had some broken spring contacts inside the LWA4P, f.e. the CAN_ERB_H and CAN_ERB_L. That's why my CAN modules have not been recognized. I fixed it and finally it works like a charm.

edit flag offensive delete link more

Comments

Did you notice some bus off on your can interface while you had your spring contatcs throuble ? Glade your solved your problem by the way.

adrienH gravatar imageadrienH ( 2019-07-15 07:58:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-06-13 05:00:58 -0500

Seen: 159 times

Last updated: Jun 25