Ask Your Question
0

Trouble installing ros-kinetic-freenect-launch on Ubuntu 16.04

asked 2019-06-11 00:25:23 -0500

ap99 gravatar image

updated 2019-06-13 02:12:01 -0500

gvdhoorn gravatar image

I would like to have access to the feenect launch files to use them to get raw data image data from Kinect2, but when I run:

sudo apt-get install ros-kinetic-freenect-launch

I get the following error:

Reading package lists... Done Building dependency tree Reading state information... Done The following additional packages will be installed: ros-kinetic-freenect-camera ros-kinetic-libfreenect ros-kinetic-rgbd-launch The following NEW packages will be installed:
ros-kinetic-freenect-camera ros-kinetic-freenect-launch ros-kinetic-libfreenect
ros-kinetic-rgbd-launch 0 upgraded, 4 newly installed, 0 to remove and 1077 not upgraded. Need to get 254 kB of archives. After this operation, 1,252 kB of additional disk space will be used. Do you want to continue? [Y/n] Y

Err:1 http://packages.ros.org/ros/ubuntu xenial/main amd64 ros-kinetic-libfreenect amd64 0.5.1-0xenial-20180809-140106-0800 404 Not Found [IP: 64.50.236.52 80]

Err:2 http://packages.ros.org/ros/ubuntu xenial/main amd64 ros-kinetic-freenect-camera amd64 0.4.2-0xenial-20190320-144143-0800 404 Not Found [IP: 64.50.236.52 80]

Err:3 http://packages.ros.org/ros/ubuntu xenial/main amd64 ros-kinetic-rgbd-launch amd64 2.2.2-0xenial-20190320-181628-0800 404 Not Found [IP: 64.50.236.52 80]

Err:4 http://packages.ros.org/ros/ubuntu xenial/main amd64 ros-kinetic-freenect-launch amd64 0.4.2-0xenial-20190320-182632-0800 404 Not Found [IP: 64.50.236.52 80] E: Failed to fetch http://packages.ros.org/ros/ubuntu/po... 404 Not Found [IP: 64.50.236.52 80]

E: Failed to fetch http://packages.ros.org/ros/ubuntu/po... 404 Not Found [IP: 64.50.236.52 80]

E: Failed to fetch http://packages.ros.org/ros/ubuntu/po... 404 Not Found [IP: 64.50.236.52 80]

E: Failed to fetch http://packages.ros.org/ros/ubuntu/po... 404 Not Found [IP: 64.50.236.52 80]

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

What should I be doing to get the launch file I need?


Edit: output of wget :

--2019-06-13 13:15:17--  http://64.50.236.52/
Connecting to 64.50.236.52:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 54 [text/html]
Saving to: ‘index.html’

index.html          100%[===================>]      54  --.-KB/s    in 0s      

2019-06-13 13:15:18 (4.09 MB/s) - ‘index.html’ saved [54/54]

sudo apt update:

Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease                   
Get:2 http://dl.google.com/linux/chrome/deb stable Release [943 B]             
Hit:3 http://www.galil.com/sw/pub/ubuntu/16.04 xenial InRelease                
Hit:4 http://archive.canonical.com/ubuntu xenial InRelease                     
Get:5 http://dl.google.com/linux/chrome/deb stable Release.gpg [819 B]         
Get:6 http://packages.ros.org/ros/ubuntu xenial InRelease [4,678 B]            
Get:7 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages [1,102 B]
Err:6 http://packages.ros.org/ros/ubuntu xenial InRelease
The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F42ED6FBAB17C654
Get:8 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 ...
(more)
edit retag flag offensive close merge delete

Comments

Can you install any ROS packages? Are you behind a (corporate) proxy?

The error msg essentially tells you that the host packages.ros.org cannot be contacted from your PC.

gvdhoorn gravatar imagegvdhoorn ( 2019-06-11 02:03:31 -0500 )edit

I am behind a corporate proxy, But I have been able to install all the packages I needed until this one. I tried installing the Openni launch package instead but it gives similar errors to the one I posted.

ap99 gravatar imageap99 ( 2019-06-11 02:14:41 -0500 )edit

Well the error is not with the packages, but with your PC not being able to reach the packages.ros.org host.

That is a general networking issue, not a ROS issue.

Can you ping packages.ros.org and/or ping 64.50.236.52?

There has been a DNS change recently, but that was for build.ros2.org, so I don't believe it would be relevant here.

gvdhoorn gravatar imagegvdhoorn ( 2019-06-11 02:45:47 -0500 )edit

I can ping packages.ros.org and 64.50.236.52, but not 64.50.236.52 80. Is there a way to get the launch files I need for Kinect2 without installing the openni and freenect ros kinetic launch packages?

ap99 gravatar imageap99 ( 2019-06-11 19:35:26 -0500 )edit

but not 64.50.236.52 80

ignore that last one, that was a mistake (I included the port nr).

If you can ping them, what is the output of wget 64.50.236.52?

Are you behind a (corporate) proxy server by any chance? Or a firewall?

gvdhoorn gravatar imagegvdhoorn ( 2019-06-12 02:10:37 -0500 )edit

I only now noticed that apt is trying to retrieve a non-existent file from the repository. There is most likely not a connection issue.

What is the output of sudo apt update?

gvdhoorn gravatar imagegvdhoorn ( 2019-06-12 04:06:21 -0500 )edit

From what I can tell, I'm not behind a proxy. I checked the firewall using ufw status, and got: Status: inactive I'm working on a computer at university, so I'm not sure if that is causing connection issues. Are there any other ways I can test to see if I'm behind a proxy or firewall?

ap99 gravatar imageap99 ( 2019-06-12 20:32:41 -0500 )edit

Please do not use comments to post such large updates. Edit your original question.

gvdhoorn gravatar imagegvdhoorn ( 2019-06-13 01:23:33 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2019-06-13 01:24:04 -0500

gvdhoorn gravatar image
W: Failed to fetch http://packages.ros.org/ros/ubuntu/di... The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F42ED6FBAB17C654 W: Some index files failed to download. They have been ignored, or old ones used instead.

Please check #q325039.

edit flag offensive delete link more

Comments

That fixed all the issues. Thanks!

ap99 gravatar imageap99 ( 2019-06-13 16:50:24 -0500 )edit

Could you please mark the question as answered by ticking the checkmark (✓) to the left of the answer if you feel it has been answered? Thanks.

gvdhoorn gravatar imagegvdhoorn ( 2019-06-14 03:12:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-06-11 00:00:15 -0500

Seen: 1,550 times

Last updated: Jun 13