enable_motor service in hector_quadrotor

asked 2019-06-06 04:37:38 -0500

hamed ghasemi gravatar image

hello every body. I'm using hector_quadrotor package to run drone. when I tried to simple example (outdoor_flight_gazebo.launch ) I need to run /enable_motor service with True arguments using below command :

rosservice call /enable_motors "enable: true"

but when I execute this command I got this error:

"ERROR: Unable to communicate with service [/enable_motors], address [rosrpc://hamed-ThinkPad-T510:51237] "

I see /enable_motors in rosservice list. I tried the solution in below link, but I can not run this service.

[http://answers.ros.org/question/48433...] (http://answers.ros.org/question/48433...)

can any one help me ?

thank you.

edit retag flag offensive close merge delete

Comments

Is that the only service you cannot call? How about another one in hector quadrotor, such as /take_off ? Do they also return the same error?

kosmastsk gravatar imagekosmastsk ( 2019-06-06 04:56:09 -0500 )edit

thank you for your response.

I do not see /take_off topic but I see takeoff_action/set_logger_level.


when i type "rosservice info /takeoff_action/set_logger_level " I got this message:

Node: /takeoff_action URI: rosrpc://hamed-ThinkPad-T510:46255 Type: roscpp/SetLoggerLevel Args: logger level


and when I type "rosservice info /enable_motors " I got this message: Node: /gazebo URI: rosrpc://hamed-ThinkPad-T510:40355 Type: hector_uav_msgs/EnableMotors ERROR: Unable to load type [hector_uav_msgs/EnableMotors]. Have you typed 'make' in [hector_uav_msgs]?


thank you.

hamed ghasemi gravatar imagehamed ghasemi ( 2019-06-06 08:41:07 -0500 )edit

I notice again and I see I problem with all service in gazebo and I got this error for other service that related to gazebo.

hamed ghasemi gravatar imagehamed ghasemi ( 2019-06-06 09:11:36 -0500 )edit

Did you download and build hector_uav_msgs?

kosmastsk gravatar imagekosmastsk ( 2019-06-06 10:15:31 -0500 )edit

yes I install this package.

hamed ghasemi gravatar imagehamed ghasemi ( 2019-06-06 16:08:40 -0500 )edit

Since you built the packages and then sourced the workspace again, and the same error occurs, I cannot find any other reason for not being able to run the service..

kosmastsk gravatar imagekosmastsk ( 2019-06-07 06:14:51 -0500 )edit