Ask Your Question
0

Tf_echo missing timestamp

asked 2019-06-04 04:55:05 -0600

nilot gravatar image

Hi,

I start to play my rosbag and then I start tf_echo : rosrun tf tf_echo odom map This is the output :

At time 1559381315.708

  • Translation: [0.000, 0.000, 0.000]
  • Rotation: in Quaternion [0.000, 0.000, 0.000, 1.000] in RPY (radian) [0.000, -0.000, 0.000] in RPY (degree) [0.000, -0.000, 0.000]

I am happy with this result. But now if I start tf_echo first and then I start to play the rosbag :

At time 0.000

  • Translation: [0.000, 0.000, 0.000]
  • Rotation: in Quaternion [0.000, 0.000, 0.000, 1.000] in RPY (radian) [0.000, -0.000, 0.000] in RPY (degree) [0.000, -0.000, 0.000]

You see, it doesn't display the timestamp of the rosbag but "0.000" instead. Do you have any explanation ?

Thank you

edit retag flag offensive close merge delete

Comments

1

To help you, could you please provide a bit more information such that the problem can be reproduced?

1) Which ROS version are you using? 2) Please indicate the command with which you play back the bag. 3) Please indicate the command with which you run tf_echo. 4) Which other nodes run at the same time? 5) Which parameters are set on the server?

Georg Bartels gravatar imageGeorg Bartels ( 2019-06-13 02:28:54 -0600 )edit

I use ROS melodic. I play the rosbag with "rosbag play my_bag.bag". No other node is running. I run tf_echo with "rosrun tf tf_echo odom map "

nilot gravatar imagenilot ( 2019-06-17 03:20:33 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-06-14 16:59:17 -0600

dasanche gravatar image

Does your rosbag publish a /clock topic?

edit flag offensive delete link more

Comments

No, it doesn't.

nilot gravatar imagenilot ( 2019-06-17 03:22:02 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-06-04 04:55:05 -0600

Seen: 136 times

Last updated: Jun 14