ROS Melodic rosdep install fails at ArchLinux

asked 2019-05-30 07:46:25 -0500

NelsonCandela gravatar image

updated 2022-01-22 16:09:58 -0500

Evgeny gravatar image

I was following the installation guide from the official page for a source instalation. Already installed rosdep, rosinstall_generator, wstool and rosinstall, all of them with pip3.

I had to take out --tar from rosinstall_generator desktop_full --rosdistro melodic --deps --tar > melodic-desktop-full.rosinstall, because when I leave it and execute wstool init -j8 src melodic-desktop-full.rosinstall it gave me an error Tarball unpacked failed or something like that, and it disapeared taking out the --tar.

But when I execute rosdep install --from-paths src --ignore-src --rosdistro melodic -y, it prompts me an error saying:

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies:

gazebo_dev: No definition of [libgazebo9-dev] for OS [arch]

I read that I could put -r at the end of the commnd so it would continue even if something fails, but when I ran it, I got the same error than before for gazebo, and then it tries to execute some pacman -S commands it says that failed to detect succesful installation of [python2-catkin_pkg], the same for [python2-rospkg], [python2-pygraphviz] and [python2-rosdep].

I tried to install them via pip2 but it has no effect, and I also tried to install them from aur with

pikaur -S python2-rosdep but it's unable to install it due to a missing dependency, python2-argparse doesn't exists in the aur, it just exists for python3.

There is a way to tell rosdep to search for [python-catkin_pkg], [python-rospkg], [python-pygraphviz] and [python-rosdep], the same packages but for python 3, or either install them by hand and tell rosdep where they are?

Thank you.

edit retag flag offensive close merge delete