Ask Your Question
0

File has unexpected size

asked 2019-05-30 02:53:19 -0500

jimy gravatar image

updated 2019-05-30 03:16:13 -0500

gvdhoorn gravatar image

An error occurred when I installed ros,Here's what I do:

$ sudo sh -c '. /etc/lsb-release && echo "deb http://mirrors.ustc.edu.cn/ros/ubuntu/ $DISTRIB_CODENAME main" > /etc/apt/sources.list.d/ros-latest.list'

$ sudo apt-key adv --keyserver hkp://ha.pool.sks-keyservers.net:80 --recv-key 421C365BD9FF1F717815A3895523BAEEB01FA116

$ sudo apt update

Then report an error. May I ask who knows the reason?Is it the ros mirror source that is wrong?

Get:3 http://220.112.193.195/files/1116000006474FFE/mirrors.cqu.edu.cn/ubuntu bionic/main amd64 Packages [481 kB]
Err:3 http://220.112.193.195/files/1116000006474FFE/mirrors.cqu.edu.cn/ubuntu bionic/main amd64 Packages
  File has unexpected size (1343916 != 480706). Mirror sync in progress? [IP: 220.112.193.195 80]
  Hashes of expected file:
   - Filesize:480706 [weak]
   - SHA256:a3b8443a822d1005b5a4577ede042691e4600e6597de0e76004b84678688481b
   - SHA1:d9aabcc8dcda723e7bde45f8bacbc765865edeb5 [weak]
   - MD5Sum:4f2fd4debc4d8381ac97f972a79c7286 [weak]
  Release file created at: Fri, 17 May 2019 19:32:55 +0000

Edit: Thank you for your reply. I tried to update the ros mirror source on May 28, May 29, and May 30. And i have tried using the following three mirror sources:

  1. packages.ros.org
  2. mirrors.ustc.edu.cn
  3. mirrors.tuna.tsinghua.edu.cn

But it's all the same mistake.I even installed a new ubuntu system to try.

I used the system: ubuntu18.04

It's hard to believe that all three mirror sources are having problems at the same time,So are there any other possible causes?

edit retag flag offensive close merge delete

Comments

1

As it is, this does not appear to be a ROS related problem. If you cannot solve it, I would suggest to post on a forum such as Ask Ubuntu.

gvdhoorn gravatar imagegvdhoorn ( 2019-05-30 03:09:52 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-05-30 03:04:09 -0500

gvdhoorn gravatar image

updated 2019-05-30 03:19:02 -0500

Edit:

I tried to update the ros mirror source on May 28, May 29, and May 30.

The problem is not the ROS mirrors.

The repository at 220.112.193.195/files/1116000006474FFE/mirrors.cqu.edu.cn/ubuntu is the problem.

Perhaps a grep 'mirrors.cqu.edu.cn' -r /etc/apt could help.


Original:

Is it the ros mirror source that is wrong?

The problem does not appear to be the ROS mirror (ie: USTC), but the package repository which is located at:

Get:3 http://220.112.193.195/files/1116000006474FFE/mirrors.cqu.edu.cn/ubuntu bionic/main amd64 Packages [481 kB]
Err:3 http://220.112.193.195/files/1116000006474FFE/mirrors.cqu.edu.cn/ubuntu bionic/main amd64 Packages

Notice how the error message mentions 220.112.193.195/files/1116000006474FFE/mirrors.cqu.edu.cn/ubuntu, which is not the USTC ROS mirror.

I'm not sure what 220.112.193.195/files/1116000006474FFE is exactly, you should probably know. Is that the mirror you use for Ubuntu Bionic itself?

If this problem persists (ie: even after retrying a few times, for instance tomorrow), you should contact the administrator of the Ubuntu mirror and ask them.

edit flag offensive delete link more

Comments

Thank you for your help. I went to check the website of “220.112.193.195/files/1116000006474FFE/mirrors.cqu.edu.cn/ubuntu” “220.112.193.195” this IP is not a mirror IP,Then I looked up the location of the IP, which was very close to my company, and I thought it might be a problem with the company network, maybe some wrong domain name mapping or something.

Finally I switched to my phone's Internet connection, and I've solved the problem。

Your advice is very helpful. Thank you very much。

jimy gravatar imagejimy ( 2019-05-30 20:13:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-05-30 02:53:19 -0500

Seen: 154 times

Last updated: May 30