3 kinects dont work , but any 2 of them work perfectly for navigation

asked 2019-05-21 06:13:24 -0500

updated 2019-05-21 13:01:21 -0500

jayess gravatar image

Goof afternoon dear ROS community. I have a big problem with my robot. I`m trying to make good navigation.

  • ROS : Kinetic on Ubuntu 14 OS.
  • Global planning : Global_planner
  • Local planning - DWA_local_planner
  • drivers for kinect - Openni Driver
  • obsctacle_detecion launch file includs rtabmap_obstacle_detector
  • My PC has intel core i5 and 8Gb DDR4 RAM on it.
  • All kinects are connected to seperate USB 3.0 buses.

The Problem:

If I launch three kinects for detecting obsctales (left, front, right sides) after a 1-2 minutes of working it freezes and two kinects stop publishing data. Rviz doesn not update obstacle cloud, navigation breaks down. The front kinect continue woking fine, but left and right stop publishing data.

What i tried to do:

Of course, to use only front and left / front and right / right and left kinects. It works! but when i launch three of them after sometime two die.

I looked at depth_registered/points , it stops publish data and obstacle_cloud, of course, does not update either. Also i tried to connect kinects to separate USB 2.0 buses but i didnt help.

If you need addition info or logs or screenshots - tell me, i will suply you with it.

Thanks if you need more

edit retag flag offensive close merge delete