Image transport built with colcon in ROS2 states "Plugins are not built"

asked 2019-05-13 05:54:25 -0500

amargs gravatar image

I wrote a test image transport based on the "Writing a new transport" tutorial, but adapted to ROS2. I sucessfully built it using colcon and sourced the setup file. If I run "ros2 pkg list", my transport is listed there. If I run "ros2 run image_transport list_transports", it is also listed there, but states "image_transport/resized (): Not available. Try 'catkin_make --pkg resized_image_transport'." and below " Plugins are not built. *".

I'm confused, why is it suggesting to run catkin_make? Shouldn't I be using colcon instead?

I also noticed that the same message appears under the theora image transport, and I installed it using the "ros-crystal-image-transport-plugins" package. I also tried to build it with colcon and it still displayed the "plugins are not built" message. Only compressed and compressed_depth look fine.

Am I missing something? Should I run something else instead? If you need more information I can provide it.

edit retag flag offensive close merge delete

Comments

I don't know about the rest, but the fact that you get a message asking about whether you've run catkin_make is shown to you just because that hasn't been updated when image_transport was ported.

gvdhoorn gravatar imagegvdhoorn ( 2019-05-13 07:54:12 -0500 )edit