Ask Your Question
0

Errors launching ur robots in gazebo

asked 2019-04-29 08:45:06 -0500

lr_k123 gravatar image

updated 2019-04-30 01:37:20 -0500

jayess gravatar image

I am new to universal_robots and want to start doing simulations in gazebo with the ur5. After following the ur-gazebo installation instructions I tried

$ roslaunch ur_gazebo ur5.launch

However, I get many errors and do not know how and where to fix them.

Maybe I need to change/add something in a urdf/xacro file for the gazebo_ros_control plugin ( ??), but I don't know which file and what to do. Can someone help me?

I am using Ubuntu 16.04.6 LTS, ros kinetic ,and gazebo 7

This is the log info::

$roslaunch ur_gazebo ur3.launch ... logging to /home/philips/.ros/log/703f6ffa-6a81-11e9-9117-6038e0d93719/roslaunch-philips-HP-EliteDesk-800-G1-SFF-21350.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://philips-HP-EliteDesk-800-G1-SFF:46689/

SUMMARY
PARAMETERS * /arm_controller/action_monitor_rate: 10 * /arm_controller/constraints/elbow_joint/goal: 0.1 * /arm_controller/constraints/elbow_joint/trajectory: 0.1 * /arm_controller/constraints/goal_time: 0.6 * /arm_controller/constraints/shoulder_lift_joint/goal: 0.1 * /arm_controller/constraints/shoulder_lift_joint/trajectory: 0.1 * /arm_controller/constraints/shoulder_pan_joint/goal: 0.1 * /arm_controller/constraints/shoulder_pan_joint/trajectory: 0.1 * /arm_controller/constraints/stopped_velocity_tolerance: 0.05 * /arm_controller/constraints/wrist_1_joint/goal: 0.1 * /arm_controller/constraints/wrist_1_joint/trajectory: 0.1 * /arm_controller/constraints/wrist_2_joint/goal: 0.1 * /arm_controller/constraints/wrist_2_joint/trajectory: 0.1 * /arm_controller/constraints/wrist_3_joint/goal: 0.1 * /arm_controller/constraints/wrist_3_joint/trajectory: 0.1 * /arm_controller/joints: ['shoulder_pan_jo... * /arm_controller/state_publish_rate: 25 * /arm_controller/stop_trajectory_duration: 0.5 * /arm_controller/type: position_controll... * /joint_state_controller/publish_rate: 50 * /joint_state_controller/type: joint_state_contr... * /robot_description:

NODES / arm_controller_spawner (controller_manager/controller_manager) fake_joint_calibration (rostopic/rostopic) gazebo (gazebo_ros/gzserver) gazebo_gui (gazebo_ros/gzclient) joint_state_controller_spawner (controller_manager/controller_manager) robot_state_publisher (robot_state_publisher/robot_state_publisher) spawn_gazebo_model (gazebo_ros/spawn_model)

auto-starting new master
process[master]: started with pid [21363]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 703f6ffa-6a81-11e9-9117-6038e0d93719 
process[rosout-1]: started with pid [21376] started core service [/rosout] 
process[gazebo-2]: started with pid [21394] 
process[gazebo_gui-3]: started with pid [21405] 
process[spawn_gazebo_model-4]: started with pid [21407] 
process[robot_state_publisher-5]: started with pid [21411] 
process[fake_joint_calibration-6]: started with pid [21413] 
process[joint_state_controller_spawner-7]: started with pid [21419] 
process[arm_controller_spawner-8]: started with pid [21422] 
[ INFO] [1556543978.895013105]: Finished loading Gazebo ROS API Plugin. 
[ INFO] [1556543978.898086697]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting... 
[ INFO] [1556543978.933172434]: Finished loading Gazebo ROS API Plugin. 
[ INFO] [1556543978.933412241]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting... SpawnModel script started
[INFO] [1556543979.218704, 0.000000]: Loading model XML from ros parameter
[INFO] [1556543979.220555, 0.000000]: Waiting for service /gazebo/spawn_urdf_model 
[ INFO] [1556543979.437002215, 0.022000000]: waitForService: Service [/gazebo/set_physics_properties] is now available. 
[ INFO] [1556543979.470231108, 0.054000000]: Physics dynamic reconfigure ready.
[INFO] [1556543979.522646, 0.105000]: Calling service /gazebo/spawn_urdf_model 
[ERROR] [1556543979.526850890, 0.109000000]: Exception thrown while processing service call: Time is out of dual 32-bit range Service call failed: service [/gazebo/spawn_urdf_model] responded with an error: Time is out of dual 32-bit range 
[ INFO] [1556543979.717137582, 0.154000000]: Loading gazebo_ros_control plugin 
[ERROR] [1556543979.717291090, 0.154000000]: GazeboRosControlPlugin missing while using DefaultRobotHWSim, defaults to true. This setting assumes you have an old package with an old implementation of DefaultRobotHWSim, where the ...
(more)
edit retag flag offensive close merge delete

Comments

Hey.

But are you able to visualize the robot?

pmuthu2s gravatar imagepmuthu2s ( 2019-04-29 09:27:13 -0500 )edit

Hey, Yes the robot is vizualized in the gazebo world.

lr_k123 gravatar imagelr_k123 ( 2019-04-29 09:31:15 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-04-29 09:38:41 -0500

pmuthu2s gravatar image

updated 2019-04-29 09:39:11 -0500

Hey!

From the log you have posted, you can see that

[ WARN] [1556543979.957337287, 0.155000000]: Please set gazebo_pid parameters, switch to the VelocityJointInterface or EffortJointInterface, or upgrade to Gazebo 9.
[ WARN] [1556543979.957347145, 0.155000000]: For details, see https://github.com/ros-simulation/gazebo_ros_pkgs/issues/612

You can check that github link to tackle the issue if you want all the errors to be gone.

But as an alternate, you can also look into this issue from github

This will solve your problems.

edit flag offensive delete link more

Comments

Hey, thank you for answering! I tried to clone the package from https://github.com/ros-simulation/gaz... . I try to launch the gazebo.launch file, but it shows the following:

philips@philips-HP-EliteDesk-800-G1-SFF:~/catkin_ws$ source devel/setup.bash
philips@philips-HP-EliteDesk-800-G1-SFF:~/catkin_ws$ ls -a
.  ..  build  .catkin_workspace  devel  mimic_joint_gazebo_tutorial  roboticsgroup_gazebo_plugins  src
philips@philips-HP-EliteDesk-800-G1-SFF:~/catkin_ws$ ls mimic_joint_gazebo_tutorial/launch
gazebo.launch  show_model_rviz.launch
philips@philips-HP-EliteDesk-800-G1-SFF:~/catkin_ws$ roslaunch mimic_joint_gazebo_tutorial gazebo.launch
[gazebo.launch] is neither a launch file in package [mimic_joint_gazebo_tutorial] nor is [mimic_joint_gazebo_tutorial] a launch file name
The traceback for the exception was written to the log file

Or would you advice to follow the alternative option(https://github.com/ros-industrial/universal)

lr_k123 gravatar imagelr_k123 ( 2019-04-30 02:36:44 -0500 )edit

You can try the alternate link!

But as such you can just leave the bug "not noticed" and start working on your intended application. There won't be any problem.

pmuthu2s gravatar imagepmuthu2s ( 2019-04-30 02:55:32 -0500 )edit

Okay thank you!

lr_k123 gravatar imagelr_k123 ( 2019-05-01 05:28:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-04-29 08:45:06 -0500

Seen: 220 times

Last updated: Apr 30