Ask Your Question
1

[Autoware 1.11.0] No twist command output with autoware quick start (autoware launcher)

asked 2019-04-27 00:26:08 -0600

rwong gravatar image

Setup

Issue

[Note: I’m fairly new to autoware]
I’m trying to get the demo running using autoware launcher. However, I’m not getting any output from the /twist_cmd topic; rostopic echo /twist_cmd shows nothing.

In my investigation, I found that pure pursuit isn’t happy as the necessary topics are not subscribed yet; I’m seeing this in the logs:
Necessary topics are not subscribed yet ...

From the pure pursuit source code (ros/src/computing/planning/motion/packages/waypoint_follower/nodes/pure_pursuit/pure_pursuit_core.cpp), I can see that four conditions need to be met, i.e. the pose, velocity, waypoints and config have to be set. This makes perfect sense.

I then checked if all the subscribed topics have outputs by using “rostopic echo” on them:

  • /current_pose [✓]
  • /current_velocity [✓]
  • /final_waypoints [✗]
    • I still need to do more investigation on this to find out why this is the case.
  • /config/waypoint_follower [✗]
    • This one is weird. It outputs the pure pursuit configuration parameters only when the pure pursuit node is relaunched. It seems as though the publisher isn’t latching the output, though it doesn’t appear that way according to autoware_launcher/plugins/leaf/pure_pursuit.xml.

There is also another thing I found: image description

A new launch file might be needed there, though I’m not entirely sure if this is contributing to the problem I’m facing.

Procedure to reproduce the problem

  1. Run docker/generic/run.sh -t 1.11.0 on host.
  2. Place the sample data file from here ( https://github.com/autowarefoundation... ) into the ~/.autoware directory, i.e.

    mkdir -p ~/.autoware/log  
    ln -sf ~/shared_dir/data ~/.autoware/data  
    ln -sf ~/shared_dir/sample_moriyama_150324.bag ~/.autoware/log/20150324.bag  
    cd ~/.autoware/data  
    ln -sf ./map/pointcloud_map .  
    ln -sf ./map/vector_map .
    
  3. Modify velocity_set.yaml and obstacle_avoid.yaml in autoware_launcher/share/autoware_launcher/plugins/refs such that:

    obstacle_avoid.yaml:

    @@ -1,5 +1,5 @@
    format: Autoware Launcher Plugin Version 0.1
    -rosxml: $(find astar_planner)/launch/obstacle_avoid.launch
    +rosxml: $(find waypoint_planner)/launch/astar_avoid.launch
    args:
    - {name: use_2dnav_goal, type: bool, default: false}
    - {name: map_frame, type: str, default: map}
    

    velocity_set.yaml:

    @@ -1,5 +1,5 @@
    format: Autoware Launcher Plugin Version 0.1
    -rosxml: $(find astar_planner)/launch/velocity_set.launch
    +rosxml: $(find waypoint_planner)/launch/velocity_set.launch
    args:
    - {name: use_crosswalk_detection, type: bool, default: true}
    - {name: points_topic, type: str, default: points_no_ground}
    

    This changes were made because the existing names reference the old package name and launch file name.

  4. Launch autoware launcher

    cd ~/Autoware/ros
    ./run-experimental
    
  5. Play back the bag file and launch all modules.

  6. Verify that you're getting the same problem I've described above.

Thank you for looking into this. Any input or insight will be greatly appreciated!

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2019-05-14 09:57:13 -0600

yuki gravatar image

Hello rwong. This problem is caused by a mismatch of the node name (obstacle_avoid/astar_avoid) and the wrong arguments. I have confirmed that demo works with the sample data by merging this PR.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-04-27 00:26:08 -0600

Seen: 293 times

Last updated: Apr 27 '19