Ask Your Question
1

ROS and Open Vino

asked 2019-04-24 22:19:35 -0600

rukie gravatar image

updated 2019-04-25 01:57:32 -0600

gvdhoorn gravatar image

Hello! I'm interested in running the Neural Compute Stick 2 with ROS, in Python. The first Neural Compute Stick used the NCSDK which provided Python 2.7 support. OpenVINO doesn't seem to have any plans for Python 2.7 support (requirements). I'm not particularly skillful with C code, so I'm curious if anyone else has gotten OpenVINO to work with ROS1+Python.

What are my options here? As I'm running a simulation in Unity and communicating over a ros websocket (like the LG Simulator), would roslibpy be a good option? I think that could be installed with python3 to connect over the rosbridge/websocket.

Note: Confusingly it seems like there might be some 2.7 support per here

edit retag flag offensive close merge delete

Comments

@rukie Depending on what ros distro you are using (and also which packages you are using), you can potentially use Python3 in your setup with ROS 1 and not run into too much trouble. You could also try ROS 2, which requires Python 3.

allenh1 gravatar imageallenh1 ( 2019-04-25 09:04:55 -0600 )edit

@allenh1 I'm using ROS Kinetic on Ubuntu 16.04. Which ROS version would have the best Python3 support? I assume Melodic?

I previously stuck with Kinetic because it appears to have best support for online tutorials (and it seems like Indigo is in all the books). Though I'm getting to a point that I'm not so reliant on existing packages and tutorials.

rukie gravatar imagerukie ( 2019-04-25 10:30:05 -0600 )edit
rukie gravatar imagerukie ( 2019-04-25 11:04:29 -0600 )edit

@rukie: the blog documents 3 steps, 1 of which is optional (the rostest one) and gives the exact commands.

gvdhoorn gravatar imagegvdhoorn ( 2019-04-25 13:15:07 -0600 )edit

And I assume all of these apt packages should be ignored?

python3-catkin-pkg python3-catkin-pkg-modules python3-dateutil python3-docutils python3-pygments python3-pyparsing python3-roman python3-rosdep python3-rosdistro python3-rosdistro-modules python3-rospkg python3-rospkg-modules

rukie gravatar imagerukie ( 2019-04-25 15:18:25 -0600 )edit

I'm not sure what you mean by "ignored" here... If you mean "not installed" then no, you probably need them.

allenh1 gravatar imageallenh1 ( 2019-04-25 15:25:57 -0600 )edit

@allenh1 If I try to install a python3-catkin-pkg it wants to uninstall all of ros-melodic. I don't understand how those packages might play into a ROS and Python3 environment.

rukie gravatar imagerukie ( 2019-04-25 16:25:49 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2019-12-07 22:11:58 -0600

songshan gravatar image

I have written a easy-to-use ROS wrapper for OpenVINO R3 Inference Engine, with a step-by-step instruction! =) https://github.com/songshan0321/ros_vino

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2019-04-24 22:19:35 -0600

Seen: 129 times

Last updated: Dec 07 '19