Running KITTI - Raw Data on cartographer_ros, have problem in vehicle's output pose

asked 2019-04-11 04:04:22 -0500

nobinov gravatar image

Hi all! I'm currently using cartographer_ros for SLAM using KITTI dataset. I'm using ROS Melodic in Ubuntu 18.04.

I installed cartographer and cartographer_ros in early march. I am using Raw Data from data category Road which is 2011_10_03_drive_0042 (synced+rectified data) and convert it to rosbag using kitti2bag.

To run it, I followed and adapted an example from gmukitti and slightly edit some configuration to be compatible with current version of cartographer_ros. After I run it, I got result like this, which is have a wrong result pose that make the path "squished" and make the map looks terrible : image description

Since it's heavily related to the cartographer itself (may be related to configuration used), I'm already ask this problem in issues section of cartographer_ros in github. Detail of my question (+ configuration which I used) can be looked at https://github.com/googlecartographer/cartographer_ros/issues/1251. I re-ask the question in here to make it discoverable with larger audiences.

I also ask this question here because it may be related to the data in rosbag itself. In my current bag, the IMU it pointing upwards. I tried to inverse the value of linear_acceleration (x,y,z) so it pointing downwards. But it still have a bad result.

image description

image description

Anyone have any ideas how to fix this?

edit retag flag offensive close merge delete