Why move_base node doesn't work with the robot_upstart library?

asked 2019-04-08 07:29:24 -0500

samadrigal7 gravatar image

Hello Everybody

I am using a waffle pi turtlebot3 with Ubuntu mate 16.04 OS and ROS kinetic version. So, the idea is, when a I turn on the turtlebot3, my application should to startup too. So, I installed the robot_upstart from clearpath to try to performe it at this way. At the beginnig, I did my application run with a daemon, and when I turn on the turtlebot3 with only the [turtlebot3_bringup turtlebot3_robot.launch], this one works. Then I add in my application the [turtlrbot3_navigation amcl.launch] and also the map, and these work too. However, when I tried to add the [turtlebot3_bringup turtlebot3_model.launch] and [turtlebot3_navigation move_base.launch], these ones always kill all the nodes. Furthermore, when I run only the [turtlebot3_navigation move_base.launch] with the deamon, and the others nodes I run it in the linux shell, the move_base.launch didn't work. Is it possible to use the [turtlebot3_navigation move_base.launch] with the robot_upstart library to startup an application when the turtlebot3 turn on?

edit retag flag offensive close merge delete