Ask Your Question
0

frontier_exploration installation can't locate explore_client and explore_server in its package.

asked 2019-04-02 05:26:22 -0500

ZeroSan gravatar image

updated 2019-04-02 05:27:26 -0500

Hi everyone. I'm running ROS Kinetic on Raspberry Pi.

So it seems that frontier_exploration package was successfully built via git clone https://github.com/paulbovbel/frontier_exploration.git and catkin_make.

I've also downloaded global_map.launch and created a launch folder within frontier_exploration folder since it was not generated after installation.

However, running roslaunch frontier_exploration global_map.launch returns the following error:

ERROR: cannot launch node of type [frontier_exploration/explore_client]: can't locate node [explore_client] in package [frontier_exploration] 
ERROR: cannot launch node of type [frontier_exploration/explore_server]: can't locate node [explore_server] in package [frontier_exploration]

I have tried with ROS Melodic and the same error is printed after attempting to run. What could be the problem?

Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-04-02 10:52:36 -0500

ZeroSan gravatar image

It seems that the launch file is in exploration_server folder. Running rosrun exploration_server exploration.launch worked.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-04-02 05:26:22 -0500

Seen: 296 times

Last updated: Apr 02 '19