Ask Your Question
0

RLException: while processing /home/kaos5-q/catkin_ws/src/turtlebot3/turtlebot3_bringup/launch/includes/description.launch.xml:

asked 2019-03-29 15:45:34 -0500

turtlebot3 gravatar image

updated 2019-03-30 15:41:00 -0500

jayess gravatar image

To start up I'm trying to run Rviz on my remote pc but there's a step that gives me an error. By the way I'm following the steps on the following website |section 7|. http://emanual.robotis.com/docs/en/pl...

Something that might be useful to know

  1. I'm running melodic on remote pc, Ubuntu 18.04.
  2. I'm running kinetic on turtlebot pc, Ubuntu MATE 16.04.

    • To begin with I run roscore on my remote pc.
    • Second- I ran roslaunch turtlebot3_bringup turtlebot3_robot.launch on my turtle pc.

Those steps work completely fine. Now I'm supposed to export TURTLEBOT3_MODEL=${TB3_MODEL}on my remote pc so it recognizes my turtle pc. In this case I don't have too because I've permanently set the export settings. So the next step will be running roslaunch turtlebot3_bringup turtlebot3_remote.launch on my remote pc but this step prints out this error on my terminal!

... logging to /home/kaos5-q/.ros/log/d1a5ea46-5260-11e9-ad66-7085c28192a7/roslaunch-kaos5q-desktop-4477.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

xacro: in-order processing became default in ROS Melodic. You can drop the option.
substitution args not supported:  No module named 'rospkg'
when processing file: /home/kaos5-q/catkin_ws/src/turtlebot3/turtlebot3_description/urdf/turtlebot3_burger.urdf.xacro
RLException: while processing /home/kaos5-q/catkin_ws/src/turtlebot3/turtlebot3_bringup/launch/includes/description.launch.xml:
Invalid <param> tag: Cannot load command parameter [robot_description]: command [/opt/ros/melodic/lib/xacro/xacro --inorder '/home/kaos5-q/catkin_ws/src/turtlebot3/turtlebot3_description/urdf/turtlebot3_burger.urdf.xacro'] returned with code [2]. 

Param xml is <param command="$(arg urdf_file)" name="robot_description"/>
The traceback for the exception was written to the log file

I'm kind of new to this area of ROS and working with terminal so please excuse my ignorance.

edit retag flag offensive close merge delete

Comments

Please don't use an image to display text. Images are not searchable and people cannot copy and paste the text from the image. Please update your question with a copy and paste of the error instead.

jayess gravatar image jayess  ( 2019-03-29 16:35:39 -0500 )edit

I apologize for the image. I think I've fixed the problem! Let me know if I have to change anything else.

turtlebot3 gravatar image turtlebot3  ( 2019-03-29 17:01:03 -0500 )edit
2

No worries. If you think that you've fixed your problem, then could you please post it as an answer when you're sure?

jayess gravatar image jayess  ( 2019-03-30 00:18:44 -0500 )edit

I haven't been able to solve the problem!!! :/ I've been having this problem for a long time but I haven't been able to post this.

turtlebot3 gravatar image turtlebot3  ( 2019-03-30 12:02:02 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-03-30 14:15:13 -0500

130s gravatar image

Not exactly sure what you originally wanted to do, but I just try to answer for the error you posted.

roslaunch failure seems to be happening because parsing xacro file somehow failed. Why that happened is not clear to me. I'd suggest:

  • xacro file passed is valid by something like #q9208
  • rospkg might be missing, so install it.
edit flag offensive delete link more

Comments

I've already installed rospkg. I've never had this issue before and I don't know why is doing it!!

turtlebot3 gravatar image turtlebot3  ( 2019-03-30 15:06:46 -0500 )edit

I have the same error, if you've solved it, could you please tell me how?

Adi_0906 gravatar image Adi_0906  ( 2020-05-13 09:25:35 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-03-29 15:45:34 -0500

Seen: 1,707 times

Last updated: Mar 30 '19