Ask Your Question
0

catkin_make failing, looking for argparse

asked 2019-03-27 10:10:30 -0600

bakerhillpins gravatar image

updated 2019-03-28 13:50:10 -0600

I've burned a day searching around for a solution and have had no luck. I'm trying to get an install of ROS for Windows running and have followed the basic install instructions here. The install of ros-melodic-desktop worked (with the exception of vcredist140/v14.16.27027.1 because the install of VS community has a newer version/v14.16.27029.1) with these packages installed:

  The upgrade of ros-melodic-desktop was successful.
  Software installed to 'c:\opt\ros

Upgraded:
 - kb2919355 v1.0.20160915
 - kb3033929 v1.0.4
 - kb2999226 v1.0.20181019
 - ros-catkin-tools v0.0.1.1903221831
 - ros-python2 v2.7.15.1809242354
 - ros-melodic-desktop v20190325.1
 - kb2919442 v1.0.20160915
 - kb3035131 v1.0.2

SO I moved on to the tutorials which start with creating the catkin workspace. When I run catkin_make I end up with the following relatively commonly reported problem (google search) with packages referencing python2.7

  pkg_resources.DistributionNotFound: The 'argparse' distribution was not
  found and is required by catkin-pkg

All of these problem reports link back to the fact that argparse is not a separate package in P2.7 and suggest removing it from the required list. I tried that solution and just banged into the next missing dependency.

CMake Error at C:/opt/ros/melodic/x64/share/catkin/cmake/empy.cmake:29 (message):
  Unable to find either executable 'empy' or Python module 'em'...  try
  installing the package 'python-empy'

Am I missing something basic here? It would seem that others have been able to install melodic and get the workspace up and running.

I hope I've picked the correct tags. There seems to be several dozen "windows" tags with little consensus on which the MS devs are watching. The tags box at the bottom of the new question submit form filters out most of the tags I would think are relevant based upon the larger search results you get when searching in the forum.

[HELP] I can search on the tag "Windows" in the tag search in the right hand column but I can't actually edit and add that tag to the post!

edit retag flag offensive close merge delete

Comments

You most likely hit this issue: https://github.com/ms-iot/ROSOnWindow... Please kindly check it out and see if the resolution works for you. Thanks!

Sean Yen gravatar imageSean Yen ( 2019-03-27 17:14:45 -0600 )edit

@Sean Yen ~~I gave the suggested workaround a try but same results~~ I left a comment on the issue in GitHub.

Correction: I botched argparse (argSparse) in requires.txt. I corrected requires.txt and executed the catkin_make again.

It's now reporting the dependency PY_em missing:

-- Could NOT find PY_em (missing: PY_EM)
CMake Error at C:/opt/ros/melodic/x64/share/catkin/cmake/empy.cmake:29 (message):
  Unable to find either executable 'empy' or Python module 'em'...  try
  installing the package 'python-empy'
Call Stack (most recent call first):
  C:/opt/ros/melodic/x64/share/catkin/cmake/all.cmake:163 (include)
  C:/opt/ros/melodic/x64/share/catkin/cmake/catkinConfig.cmake:20 (include)
  CMakeLists.txt:56 (find_package)
bakerhillpins gravatar imagebakerhillpins ( 2019-03-28 07:49:01 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2019-03-28 13:47:04 -0600

bakerhillpins gravatar image

This has been fixed with the help of @Sean Yen and @OoeyGUI. @Sean Yen worked through the issue with me via this GitHub issue report.

Short story: The following command fixed my install

choco upgrade -y --force ros-melodic-desktop

Afterward I noted that the command to install ROS for Windows under the Binary Package Installation section here changed from:

choco upgrade ros-melodic-desktop -y

to

choco upgrade ros-melodic-desktop_full -y

so it might have stemmed from not downloading the full package on the initial install.

edit flag offensive delete link more
0

answered 2019-03-27 14:15:21 -0600

OoeyGUI gravatar image

updated 2019-03-27 14:20:23 -0600

Thank you for the report. Looking at this now.

[edit] as a work around, you can do a

pip install argparse

Then rerun the rosdeps script:

c:\ProgramData\chocolatey\lib\ros-melodic-desktop\tools\rosdepInstall.bat

Working on a real fix.

edit flag offensive delete link more

Comments

Unfortunately the workaround didn't work for me. The pip install was successful:

C:\Windows\System32>pip install argparse
Collecting argparse
  Downloading https://files.pythonhosted.org/packages/f2/94/3af39d34be01a24a6e65433d19e107099374224905f1e0cc6bbe1fd22a2f/argparse-1.4.0-py2.py3-none-any.whl
Installing collected packages: argparse
Successfully installed argparse-1.4.0

But I still encountered

The 'argsparse' distribution was not found and is required by catkin-pkg

Let me know if I can be of any help otherwise.

[edit] - So the problem encountered here was I botched adding argparse back into the file and added an extra 'S'. Note the argSparse. After fixing that I still encountered the dependency PY_em missing error described in the comments under the OP.

bakerhillpins gravatar imagebakerhillpins ( 2019-03-28 07:53:49 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-03-27 10:10:30 -0600

Seen: 204 times

Last updated: Mar 28