Ask Your Question

No data received even though topics are not empty

asked 2019-03-26 05:16:03 -0500

EdwardNur gravatar image

I am using RTABmap and having a camera on a seperate machine which sends image_rect/compressed over the WiFi to my host PC. My tree looks very standard and non-broken and every topic is not empty, they are published but when I try to run rtabmap I get this error:

[ WARN] [1553595152.413459752]: /rtabmap/rtabmapviz: Did not receive data since 5 seconds! Make sure the input topics are published ("$ rostopic hz my_topic") and the timestamps in their header are set. If topics are coming from different computers, make sure the clocks of the computers are synchronized ("ntpdate"). If topics are not published at the same rate, you could increase "queue_size" parameter (current=10).
/rtabmap/rtabmapviz subscribed to (approx sync):

Why is it stating that? I have every topic that is mentioned above and running at the same 30hz rate.

edit retag flag offensive close merge delete


What is the output of echo $ROS_MASTER_URI for each machine ?

Delb gravatar image Delb  ( 2019-03-26 05:33:49 -0500 )edit

@Delb on my embedded machine it is: http://HOSTPC_IP:11311/ On my host pc: http://localhost:11311

EdwardNur gravatar image EdwardNur  ( 2019-03-26 05:49:45 -0500 )edit

Which node is publishing /odom? Are the stamps matching between odom and the image topics?

matlabbe gravatar image matlabbe  ( 2019-03-31 16:28:36 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2019-03-26 05:59:28 -0500

Delb gravatar image

updated 2019-03-26 06:01:00 -0500

You need to set ROS_MASTER_URI to the ip address of the computer running roscore on both machines. For example, if you run roscore on your host pc, you should then do on your embedded machine :

export ROS_MASTER_URI=http://HOSTPC_IP:11311/
edit flag offensive delete link more


Thanks for the answer, but how then I worked before? I did not set that on my host pc and sometimes I did manage RTABMAP to work

EdwardNur gravatar image EdwardNur  ( 2019-03-26 06:07:25 -0500 )edit

You mean it was working before without setting those parameters ? On which machine were you usually running roscore ?

Delb gravatar image Delb  ( 2019-03-26 06:14:57 -0500 )edit

@Delb Yes, I used the same machine

EdwardNur gravatar image EdwardNur  ( 2019-03-26 07:06:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2019-03-26 05:16:03 -0500

Seen: 232 times

Last updated: Mar 26 '19