Ask Your Question
0

All spaces are occupied using RTABmap stereo

asked 2019-03-24 13:21:51 -0500

EdwardNur gravatar image

Hi,

I am trying to map the area using the stereo camera and after looking at produced map, all the cells are black, meaning occupied. I have tried to figure out for 2 days but still struggling to understand the reason.

Will it be possibe for someone to have a look at my database? I clearly doing something wrong. Also, as soon as I start RTABmap, the framerate drops to 20 hz from 30 hz and the images lag.

My RTAB database: https://drive.google.com/file/d/1sSgH...

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-03-31 15:27:37 -0500

matlabbe gravatar image

The camera is looking up. There is a missing optical rotation that could be fixed by rotating the base frame of the camera:

<arg name="pi/2" value="1.5707963267948966" />
<arg name="optical_rotate" value="0 0 0 -$(arg pi/2) 0 -$(arg pi/2)" />
<node pkg="tf" type="static_transform_publisher" name="camera_base_link" args="$(arg optical_rotate) base_link stereo_camera 100" />

Then make sure to set frame_id parameter of rtabmap to base_link (or whatever is your robot base frame).

cheers,
Mathieu

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-03-24 13:21:51 -0500

Seen: 70 times

Last updated: Mar 31 '19